MotoZ Play issue with sending group texts

Hello, I am a former iPhone user, and just switched to a MotoZ Play.  I am having issues with sending group texts.  Some go through but others do not.  I've tried the Verizon step by step troubleshooting, but am still not having luck.  Most of my friends are on iPhones... and I'm using Verizon messaging.  What to do?  Thanks!

Labels (1)
Re: MotoZ Play issue with sending group texts
Customer Service Rep

Dexter11, I certainly can understand your concern here. I had this happen to my son when he switched from iPhone to Android. You may need to deregister iMessage. You can do that by following these steps:

How to unlink iMessage from a phone number :Step 1: Sign in with your Apple ID at: Step 2: If you no longer own the device, click on the iPhone you wish to unregister. Step 3: Click on the Unregister button and confirm this action. Step 4: A validation screen will appear.


Follow us on TWITTER @VZWSupport If my response answered your question please click the Correct Answer button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!