New update to my DROID Turbo, now it is malfunctioning?

I recently received an "update system" request (@about 9pm CMT on 07/24/2015) for my DROID Turbo, and the phone is still relatively new. I went ahead and clicked on the notification to allow the system to update (@ 1am CMT on 07/25/2015). I left if aside for 15 minutes, picked it back up then a white screen with small red and blue squiggly lines appear across the screen for a second then turns off. I plugged it to the charger and let it charge for a bit. I tried to hold the power button to turn it back on and the "Powered by Motorola" introduction screen appears and now it flashes the charging icon. I have tried to repeatedly turn on this phone and the same instance occurs. Please, I do not care if the phone is malfunctioning, I just really need the information that is contained with it. I cannot lose my photos and notes. What should I do? Please I need some help.

Labels (2)
Re: New update to my DROID Turbo, now it is malfunctioning?
Customer Service Rep


I understand not wanting to lose the information on the phone. We will try to do everything in our power to make sure you are able to retrieve that information.  Did you have the information backed up? To you Google account, to Verizon Cloud?  

Please try the following steps to see if you can get the phone to power on Please keep us posted.

Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!