Turbo rarely rings after Lollipop update
jbcollier22
Enthusiast - Level 2

I got the Lollipop update this morning and installed it.  Pretty quickly I noticed I wasn't getting calls.  Turns out my phone is doing the same thing it did back when I first got it (around Christmas), it just doesn't ring half the time people call.  Last time I posted on here and was able to fix it by changing my network type to LTE/CDMA.  This time its still set there, signal is still great, etc.  I've tried restarting the phone and nothing seems to help.  Thanks for any help.

Labels (2)
0 Likes
2 Replies
jbcollier22
Enthusiast - Level 2

I forgot to mention everything else works fine such as making calls, texts, etc.  Here is a link to the thread where I battled this early this year:  https://community.verizonwireless.com/thread/847608

0 Likes
vzw_customer_support
Customer Service Rep

Updates are meant to improve your device jbcollier22. I regret to learn of the difficulties you are now experiencing after the recent update. Just to clarify, are calls coming in but the phone is not ringing or are calls not showing up on your phone at all? Are you able to hear other notifications when you receive a text, email, etc.? Can you try http://vz.to/13gzckj and test service. Keep us updated.



Thank You,

MichelleS_VZW Follow us on Twitter @VZWSupport If my response answered your question please click the �Correct Answer� button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes