G3100 DHCP server problems
LeoH1
Enthusiast - Level 2

I have discovered a bug where if you use spaces in device names, eventually the G3100 DHCP server will stop leasing out IPs, probably due to it crashing or something. I specifically noticed this when setting static leases, but I believe it affects all lease types. The G3100 web interface does not allow you to use spaces or illegal characters in device names, but the FiOS app does...

I had renamed a device using the FiOS app and included a space. Later, I set a static DHCP reservation for the device. Soon after, I noticed that it didn't work anymore. I changed it back to dynamic, but it still didn't get an IP. Then I rebooted the router and then all devices could not get an IP. It wasn't until I went it and removed the spaces from the device names that the router began leasing IPs again. I could tell that the router had stopped leasing IPs by checking the LAN DHCP log, which showed no activity if devices were named improperly.

Now with devices named properly, I am able to statically and dynamically assign IPs without issue.

Firmware version is 1.3.6.27
Hardware version: 1103

11 Replies
teecrow
Enthusiast - Level 1

Thank you!! A panic was starting to set in after I couldn't figure out why the router had stopped assigning DHCP addresses...sure enough, removing the space from one of my device names in the router's interface seems to have fixed it. Even more insidious than what you described, I never used the Fios app: the device in question had evidently given itself (or had automatically assigned) a name with a space in it, and after setting that device to have a static IP, the web interface allowed me to keep that name. It seems this is the default behavior if 1) the device name has spaces in it by default AND 2) I don't attempt to edit the device name after assigning it a static IP, i.e., I never clicked in the 'Host name' box to edit the device's name.

I set all my static IPs on the router side. In order to get back into the router interface, I just set my Windows network interface configuration to assign itself a static IP, so it needn't get the IP from the router's DHCP server. Then, entered the router interface (at 192.168.1.1), edited the problematic device name, confirmed there were no other problematic device names, and changed my Windows configuration back. Very glad you noticed this -- hoping the software devs at Verizon see it.

0 Likes
Reply
grich89
Newbie

Can confirm this is still an issue with version 1.5.0.10. Just renamed devices such as "TCL TV" and "Roku Streaming Stick +" to remove all the spaces and that freed up additional IP addresses to be leased. Please fix this Verizon

0 Likes
Reply
FIOSUser32
Newbie

My G3100 has the same problem.  It has stopped issuing or renewing existing IP’s.  Short of rebooting the entire router is there a way to cycle the DHCP service?

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

How many devices do you have? Over 50? Typically the DHCP pool will not be drained unless you have a lot of devices. Try adjusting the Lease Time of DHCP under IP Address Distribution of the Advanced Setting. The default for G1100, and presumably for G3100, is 1440 minutes, which is equivalent for 24 hours.

0 Likes
Reply
FIOSUser32
Newbie

Currently have under 20 devices.     The lease time is set to 1440.  Will try to increase it to 72 hours and see if that helps. 

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

Actually you want to do the exact opposite. If you are constantly connecting and reconnecting devices, the router will still think the device is on even it is not within the connection range for 72 hours. It should be shorter for the router to dump the old DHCP leases out.

0 Likes
Reply
Genrev
Enthusiast - Level 1

I have the same issue. Where should I go and remove the spaces in the device names. Should I go to app or to the web interface? Please advise. 

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

Not quire sure what do you mean by device names?

Device name should be configured on the device.

0 Likes
Reply
Genrev
Enthusiast - Level 1

I have the same problem that LeoH described in this forum - a bug where if you use spaces in device names, eventually the G3100 DHCP server will stop leasing out IPs, probably due to it crashing or something.

My question is where do I remove spaces in the device names - using the iphone verizon app or via myfiosgateway.com login. Any other tips and tricks on optimal settings of the G3100 would be helpful. 

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

Ok. Now I understand what is going on here.

To rename the devices, you need to do that on the devices which you are trying to rename. Different branded devices have different procedures for renaming. I will not go over every possibility here. Some devices may require administrative privilege to rename, for instance, Windows operating system.

A device name is a physical name, which can be used for identification within the same network segment in place of an IP address (the NetBios Name Service can resolve a physical name into an IP address, sort of a counterpart of Address Resolution Protocol).  For this reason, I believe, IEEE recommends the device name to be UNI encoded, which does not include space and some special characters. Although you can use %20 in place of space, but G1100/G3100 does not allow the percentage sign either.

G3100 seems to take a more restrictive approach on physical names than G1100. G1100's device name can contain a space as long as the name is received through NetBios discovery. Well, G3100 enforces IEEE standards more strictly.

0 Likes
Reply
LawrenceC
Moderator Emeritus

As this thread is now two years old, it will be locked in order to keep discussions current. If you have the same or a similar question/issue we invite you to start a new thread on the topic.

0 Likes
Reply