Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
International country codes now appearing on phone
ejhonda
Member

Took a European trip with my wife back in the beginning of May. Opted in for VZW TravelPass on both our phones while we were in Europe.  Got back, cancelled the pass. Today I noticed that when my wife texts me, her number shows with a "+31" prefix (Netherlands, the country we flew out of when we came home).  I mention this to my wife, and she says that all of her phone contacts show as starting with country code +49 (Germany, one of the countries we traveled through).

I don't understand why this would be happening or how to resolve the issue.  The rep I chatted with online didn't have any idea, either.  Anyone have any experience with this and how to resolve it?

Phones are Samsung Galaxy S21, purchased directly from Samsung, model SM-G991U1

0 Likes
Re: International country codes now appearing on phone
vzw_customer_support
Customer Support

Resetting your network settings usually helps fix the issue, and powering off the device. *Rhonda

 

Re: International country codes now appearing on phone
ejhonda
Member

I will have her try this. Is resetting networks as simple as turning off the auto selection of network operators and then rebooting?

0 Likes
Re: International country codes now appearing on phone
vzw_customer_support
Customer Support

Let's back up for a moment. When you receive a call from someone in your contacts, do you see their contact name? Or only the number? Are you having any trouble with placing calls, sending text or receiving calls/text?

 

-Christopher

0 Likes
Re: International country codes now appearing on phone
mower
Member

I had a similar issue after adding a one-month international plan.  For incoming calls and texts, a "+1" country code was being added to the number, and my phone would not recognize the names of saved contacts. 

I was able to fix the issue by changing the network type from "Global" to "LTE/CDMA" and restarting the phone.  On Android 12 (Google Pixel 4A 5G) the setting can be found here:  Settings --> Network & internet --> SIMs --> Preferred network type = "LTC/CDMA"

0 Likes