Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
LTE Network Extender - Blank Screen
daxis
Member

I just got an LTE Network Extender and plugged it in to my 300 mbps home network. When it powers up, the screen is blank but the documentation indicates it should be giving me startup and status info.

I started with it on top of my kitchen cabinets and it did not seem to do anything. I moved it to the window and after an hour noticed I had better service (from 1 bar to 4). I did the #48 test to confirm it was working. I moved it back to the cabinets and it came back up and gave me extender coverage. Worked fine for 2 days and then today I noticed the extender coverage was gone (and confirmed with #48).

I cycled the power and still can't get coverage back and the screen is still blank. I think the device may be defective, but I can't see anything on the screen and I can't find any contact info from Verizon support for this device, just static troubleshooting guides. Any tips on what I can do?

0 Likes
Re: LTE Network Extender - Blank Screen
vzw_customer_support
Customer Support

I appreciate you taking the steps that you have so far to troubleshoot as I know how important it is to stay connected in your home with this product. When you cycled the power was it moved back by the window? Waht is the model of the Extedner as found on the lable? -Yale

0 Likes