Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Why is my Network Extender not working with new modem?
Cambam
Member

Several days ago my old router quit working.  I had been using a separate modem and router.  Comcast came out and gave me a Gateway router/modem combination.  While my Network Extender worked with my previous configuration until the router died, I cannot get it to work with this new modem.  All of the lights are blue, but my phone will not switch to Network Extender coverage most of the time.  Every once in awhile it does, so I know it's possible.  I have been through the whole trouble shooting process given to me by tech support with no change. Has anyone else had trouble with the Gateway?  Is it better to have a separate router and modem and connect to the router?  I am not tech savvy, AT ALL........

Labels (1)
1 Solution

Correct Answers
Re: Network Extender not working with new modem
Cambam
Member

So, I did a bunch of reading on forums and one thing I gleaned was to make sure Advanced Calling was turned off. I did that, and now it seems to be working fine. For such an easy thing to try, I’m surprised that is never mentioned in the trouble shooting guide to the Extender.

Thanks for the other info. I am going to look into a separate modem and router.

Happy New Year

View solution in original post

Re: Network Extender not working with new modem
John_Getzke
Leader
Leader

> Is it better to have a separate router and modem and connect to the router?  I am not tech savvy, AT ALL........

Its not a question of what is better, its a question of what is better for you.  Since you claim to not be tech savvy then generally speaking an AIO (all in one) device is a better fit since there are less devices for you to manage.  However from a performance perspective an AIO device almost always is worse than a separate modem and router system.  Tech savvy users will prefer a separate system because it also allows us additional troubleshooting steps such as isolating problems to either the modem or the router as well as opening the door for independent upgrades to either piece.

If your NE is not working correctly with the new AIO and it was working fine before then I would contact your ISP and request a different AIO device.  Mention the problem you are having and request a swap for another model under your modem rental agreement.

Otherwise if you have a way to test the NE from another modem+router or AIO setup then you could confirm if the problem is on the NE or not.  For example if you bring it over to a neighbors or relatives house for a quick test.  That might give you the confirmation you are looking for and the direction to go for support.

0 Likes
Re: Network Extender not working with new modem
Cambam
Member

So, I did a bunch of reading on forums and one thing I gleaned was to make sure Advanced Calling was turned off. I did that, and now it seems to be working fine. For such an easy thing to try, I’m surprised that is never mentioned in the trouble shooting guide to the Extender.

Thanks for the other info. I am going to look into a separate modem and router.

Happy New Year

View solution in original post

Re: Network Extender not working with new modem
John_Getzke
Leader
Leader

> make sure Advanced Calling was turned off.  I did that, and now it seems to be working fine.

I wasn't aware of that feature causing a problem either.  Thanks for the confirmation!

0 Likes