Unable to activate watch that was already active.
Enthusiast - Level 1

I have a galaxy watch 4 classic and it had been working fine up until the last couple weeks. It always says "emergency calls only no service". I reset the watch and the Wear App and now have a new group of issues. I will bounce from error 109 to error -9 to error 0 and finally error -6. I have chatted with the supposed techs that had zero idea how the watch works and instead wanted to focus on resetting my phone. The most recent tech actually tried tricking me to factory wiping my phone by having me boot into recovery mode and selecting "wipe data/factory reset". Had I not known what that was I would have reset my phone.

I have seen a few other older threads with no results and was hoping that maybe someone fixed their watch. I have also noticed since the pretend techs tried using a script to fix the issue that my watch no longer shows up and neither does the phone it was attached too. Guessing they want me to terminate my 4 lines and go somewhere else?