Wanted to share my experience in hopes that someone with the ability to improve things will read it. I'm not naive though, I don't expect this to go anywhere. Enjoy the book. Underlined/bold the important bits that some product owner or developer might care about. 

We switched to Verizon and took advantage of the BYOD promotion to receive a $450 verizon gift card for each device. Myself, my wife, my cousin, and his wife all signed up on the same plan with our devices. Had to wait 2 months to get the gift cards, but that's just a bad policy IMO. Not something broken. 

When we got them, my wife and I decided what we wanted from the store and I tried to checkout. First I put in my card information and was annoyed that chrome autofill doesn't work because it adds the focus back to the card input element. They have it configured to clear the input when you focus on the element again. This was a minor annoyance, just had to type out the card number. Then I added the gift cards which was kind of tedious. After I added two gift cards, it showed my $996 total to be $96, as it should. I click to submit and it said my card was declined. After it tried and failed, it didn't reset the entire form. My card info was gone, and the "use gift card" checkboxes weren't checked, but the gift card inputs were still visible. When checking the giftcard checkbox, which is meant to show the inputs, it hid the inputs. So when an error is encountered, the toggle triggered by the checkbox is flipped. Not the end of the world. Refreshed the page and everything was properly reset. Tried again and card was declined again. I had more than enough in my account to cover this and used the card that morning. I'm inclined to think it's an issue on Verizon's part. 

After the third failure I try to use the paypal integration. Get sent to paypals login page, login, see it's hooked to my bank account, and hit button to go back to verizon. Instead of getting redirected, I see a json blob that was something like `{go-to-url: "some%verizon%thing%that%wasnt%a%valid%url"}` I know it wasn't valid because I tried to navigate to it and got an error. So the paypal integration is broken as well. 

After that I tried to call but gave up after not reaching someone in 20min. Tried to use the website chat support but that hit a dead end when they needed my information to access the account I was already logged in to. Admittedly this one was on me, I was sort of paranoid and didn't have much faith in the validity of this site anymore and didn't want to share account/financial information if they couldn't prove they could already see my account as a verizon employee. 

Tried the mobile app chat support and got connect with someone. They disable auto-correct and weirdly, emojis, in the mobile app chat feature. Disabling the auto-correct was very annoying. Things like automatically adding apostrophes for words like "can't", fixing "kr" to "or", capitalizing the first letter of a sentence. Didn't realize how much I depended on that but can't imagine why they would block it. The cs rep had the same thing because they misspelled words that would be fixed by a modern auto-correct. I'm under the impression it's built into my phone but they can disable it, because it works the same everywhere else. They recommended I just bill it to my account if the card isn't working. I didn't see the option for that. Come to find out, if it's over a certain amount, "bill to account" is available. The problem is the amount should be based on the total due, not the cart total. My total due after gift cards was $96, but it disabled it based on the $996. You should disable the "bill to account" option, not hide it, and give an explanation in a tooltip. And fix the logic it uses to calculate if it's over the threshold or not. It was bad that the CS rep didn't know why it wouldn't be there either. 

CS rep #1 couldn't help me. Transferred me to CS rep #2. When they asked "What can I do for you?", I replied pretty short because I was so frustrated. I asked them to read through this chat history rather than me explaining everything we've talked about for the last 30min. I guess that was annoying for them and so I got put back in the queue. Now we get CS rep #3. They tried creating the order for me. When they did that, they sent it to me via email to complete. I got the email, clicked the link to complete it, which brought me to an "order search" screen pre-filled with the order number and location. Seems like an unnecessary step but whatever. I only need to fill in the last 4 digits of my social. I do that, and it says my social was incorrect....

So I'm pretty annoyed at this point. I'm now having to confirm they have the correct last 4 of my social, which they do. So the validation to check the last 4 of my social is broken. They end up completing the order for me, with the gift card numbers I provide them. I gave them 2 gift card numbers, and after a bit I get a receipt emailed to me. It said $450 applied from a gift card, $450 applied from a gift card, and $96 applied from a gift card. That doesn't make any sense. I tried to check the balance of my gift cards, but the two I gave to cs rep #3, throw an error when checking the balance. The other two, for my cousins, that I didn't give to the cs rep, still have a full balance. Whatever, at least the order is in. 

From this day I also found these issues:

  • I'm prompted to sign in with my finger print every time I switch sections of the app. Going to chat, prompt to sign in, do so. Then 15sec later go to bill, prompt to sign in, do so. Then go back to chat, prompt to sign in. What the heck?
  • The app doesn't store where I was to be used when I open it again. I was trying to checkout in the app, put in my card info, then needed to access my email to get the gift card numbers. I didn't stop the app, just went to the home screen, then gmail, then back to the app. It brought me to the home page. Went to the cart and my card info was gone. Was starting fresh. 
  • Every time I log into the website, you're asking me my security question. I'm not on a VPN where my IP is changing all the time or something. The security question should be on rare occasions right? Why is my email/password not good enough for normal use?
  • I can't highlight or copy text from the app support chat
  • I can't paste images/screenshots into the support chat on app or site.

Finally, after 5 hours, the order is submitted, I have the receipt showing it was, and I'm excited again for the items I'll be receiving in two days. 

Two days later, no items delivered. No tracking number sent. No order status email. Nothing. Chat rep says I need to call CS in the morning.

That brings us to today. Day 3. Call CS, they can't find my order. Don't see it on my account. I give them the order number/location and now they can see it.  After a while of being on hold while they try to figure out what's going on, they tell me the payment was never processed and she's working with someone to figure it out. Waiting on hold for a while, then I hear it start ringing again, and I'm back at the main menu, "In one or two sentences, let me know how I can help you". I'm LIVID at this point, so I just keep saying "Let me talk to someone!" until it puts me in the queue again. While in the queue, listening to the on hold music, the CS rep comes back and says, "Hey I'm still here. We're trying xyz to fix this. Just one more minute." While she's talking, I can still hear the on hold music. I figure it's just a bug or something. I go back on hold, after a few minutes, "Hi this is so-and-so, can I please have your first and last name?". The answering system put me back at the start of the queue for some reason. No way to get back to the person I was working with for the last 30min.

Defeated, I start going through the process again. I get to the point where he says, "Are you referring to the order for your hotspot in June? I don't see any orders from three days ago." This is kind of where I lost it. Somewhat loudly and angrily I explain everything that's happened and how ridiculous this is. And that I know it's not his fault obviously. This catches him off guard, he's empathetic and tries to help. After a bit with him, he says he's going to transfer me to someone in telesales support. With no hope left I say that's fine.

Enter Andrew, essentially the hero of the story. Major props to him for how he handled it. Over the next hour, we get it resolved. (Fingers crossed) Most of it was waiting on hold while he worked on it. Fine with me, I got some work done. At the end of it all, he explains the order was essentially stuck, they couldn't do a new one because the gift card balances where already at $0. They found a way to fix the order I guess. I asked to pay for 1 days shipping but he said they couldn't edit that part of the order. They could void it but it would take 24-48hrs to see the balance return to the gift cards. 

He sent me a message from his direct phone (Not sure if personal or work) and told me he would leave himself a note to get the tracking number in the morning, and send it to me, since verizon doesn't email that out apparently. He said if I had any questions or issues I could contact him at that number. That made me feel more hopeful because while I expect more issues, the real soulcrushing part is explaining the entire situation to a brand new person every time. 

As a software developer I was appalled that a company as big as verizon had such a terrible UX on their site and app. On top of a frustrating UX, the amount of bugs and disconnects in how the data is stored was baffling. I see the receipt on my account, the order number can be found, but no one can see the order on my account? What would make me feel really great at this point, is acknowledgement that this feedback reached someone on the software team. Product owner, manager, developer, back end, front end, someone. Any insight into why I had such a rough time would be a cherry on top. All in all this has been ~8hrs over 3 days from when I first tried to submit my payment. Not including typing this out. It turned what should've been a fun "buy toys with free money" experience, into an absurdly frustrating waste of time. 

6 Replies

Concise list of all the issues I've had so far. Can't edit the original post to add them to it. 

Bugs/Technical Problems
  • On mobile site, when I click "sign-out" from the community, it doesn't clear the cookie or session or whatever. if I hit "sign in" again, I'm already logged in. Security issue
  • On mobile, when trying to login to the community, my email/password isn't verified before prompting me for 2FA. So you're showing part of my number and email address
  • My phone number isn't on the list of phone numbers the CS can send authorization notifications to. I'm the account holder. If anything, the other numbers shouldn't be on the list.
  • Paypal integration is broken. After authing with paypal and clicking the button to return to verizon, I just see a json object with a url in it. Url isn't even valid if you copy and paste into browser.
  • On a failed checkout attempt that included giftcards, the gift cards are in a "half-reset" state. The checkbox is not checked, but the inputs are still filled and visible. Checking the checkbox to use the gift-card then hides the fields. Requires a manual refresh to attempt checkout again.
  • "Bill to account" option is not visible if cart balance is past threshold, even if remaining balance (after gift cards) is under threshold.
  • The order I made with the CS rep, was not attached to my account. The receipt was emailed to me, and in my documents, but the order itself didn't show up, the page to check order status said I didn't have any, and no CS rep could find the order without me giving them the order number and location code.
  • When entering the last 4 of my social to complete and order the CS rep created for me, it said I had the wrong number. Obviously I know my ssn, and verified that they have the correct number on their end.
  • This could've been a mistake on the CS rep, but in the middle of waiting on hold for a while, I was put back at the beginning of the queue. Lost all progress I had made the the CS rep over the last 30min.
Usability Flaws/Issues
  • In order to open the full message from your inbox in the community site, you have to click on the subject line. Can't click on the body of the message. No indication that the subject is clickable on mobile.
  • The CC info inputs on the website checkout form are configured to clear input on focus. This effectively disables auto-filling with chrome or a password manager since it fills the field then puts the focus there again, clearing it out.
  • Basic mobile chat features don't work within app support chat. Unable to copy from chat window, can't add images/screenshots, can't use emojis, and most annoyingly, there is no auto-correct. Little things like correcting "kr" to "or", adding an apostrophe in "cant", or capitalizing the first letter of the first word in a sentence.
  • The "bill to account" option should not be hidden if amount is over the allowed amount, it should be visible and disabled, ideally with a tooltip explaining why. CS rep kept telling me to use it and neither of us could figure out why it wasn't an option.
  • I'm prompted to sign in with my finger print every time I switch sections of the app. Going to chat, prompt to sign in, do so. Then 15sec later go to bill, prompt to sign in, do so. Then go back to chat, prompt to sign in.
  • App doesn't save your location when you go to the home screen. I didn't close the app, just went to my home screen, then clicked the app again and was brought back to the main page of the app. I was in the middle of checking out which made it more frustrating.
  • Every time I log into the website, you're asking me my security question. I'm not on a VPN where my IP is changing all the time or something. The security question should be on rare occasions right? Why is my email/password not good enough for normal use?
Contributor - Level 3

Where is the tl;dr?


@Doggo - I'll compile a concise list of issues I've experience and append that to the top of the post. Unfortunately there are so many that even without the backstory, it will be a long read.


Haha. tl;dr - The customer service reps are alright, but the site/app/back-end software is filled with bugs and UX problems. And this issue is still not resolved. Been on the phone for 2hrs today. Currently waiting on hold currently while Andrew tries to fix everything again. 

For example though, they responded to this post privately and gave me a link to authenticate my account and then work with them to address these issues. I click the link and get a message "HTTP header value exceeds the configured limit of 8192 characters". They need to write some tests or hire a kick-butt QA team. 

Customer Service Rep

Hello, Dylanbuth. Your time is valuable, so I'm glad you brought this to our attention. We want all processes to run smoothly. I'm here to help. Please check your private messages to continue. -Tracy


@vzw_customer_support - Tried to click the link you sent in the private message and (no surprise on my end) it didn't work...