Droid Moto won't power up

Today, my phone felt very warm, so I shut it down.  I waited about 15 minutes.  When I tried to power up, the phone flashed the Motorola logo and went  dark.  I tried repeatedly with the same result.  The battery had power when this started.  My next step was to plug the phone into a charger.  Now, the screen blinks on and off, showing the battery outline with a white zigzag inside, as if it were charging.  However, the screen does not show any charge is loading.  The screen also does not display a red line indicating the power level is low or absent-- only the white battery outline with a white zigzag.   Any advice would be appreciated.

Labels (1)
Re: Droid Moto won't power up
Customer Service Rep

We know how important it is to have a properly working device, VEW2206. Hopefully, your phone started back up for you.

In case it has not and you have been without for a couple days, I am truly sorry. I would like to gather a few details to help isolate the issue. Which exact Motorola Droid do you have? Has there ever been any physical or liquid damage? Do you regularly update the software when possible?


Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!