GizmoHub stopped letting me sign in
WaterRedwood
Enthusiast - Level 1

For context - my children have used Gizmo watches for YEARS.  This has NEVER been an issue.

Today my GizmoHub app (after signing me out inexplicably for the hundredth or so time) said I didn't have an account under my email. I uninstalled and reinstalled, and it kept saying the same thing.

So I created an account.

It wouldn't create the account for some reason, or it didn't seem to anyway.

So I created an account with my Google info.

It let me in, but my child's phone wasn't connected. The Help section said I had to reset it.

I went home and reset her watch.

I tried signing into the app again (because again it had logged me out inexplicably) and this time it just did not work. It said session timed out.

I tried signing in with my email and old password. It did the same thing.

I tried signing in on another device.

It claimed no connection.

I have restarted my phone, uninstalled and reinstalled the app, checked the permission settings on my phone as well as on Google, and even attempted to make a new account (which it won't let me do because my phone number is already associated with an account - maybe two at this point!) 

And then, to top it off, Verizon customer service disconnected me in the middle of a chat after an hour of moving up the chain.

This is ridiculous. Someone somewhere should be able to access Gizmo accounts and, at the very least, delete the one associated with my number so that I can set up a new one. Unless anyone here has had the happen before and has any better ideas!

0 Likes
Re: GizmoHub stopped letting me sign in
vzw_customer_support
Customer Service Rep

Goodness, WaterRedwood! We want to get your daughter's Gizmo Watch working ASAP! Please, look out for our Private Note, so we can open your account and dig into the troubleshooting.

 

*chance

0 Likes