LG G3 slow wifi after marshmallow update
Bobby1927
Enthusiast - Level 1

After the latest OTA update I have been having issues connecting to and using in home wifi.  I'm using a Linksys E1200 router with WPA security.  I have added and re-added the wifi multiple times, along with rebooting the router.  My laptop will pull 30+ mbps downloads speeds easily over wifi right next to my phone, while my phone will get .8 mbps.  Note that it is not even 1 mbps.  How can I fix this or roll back to a previous version?

Labels (2)
1 Solution
Bobby1927
Enthusiast - Level 1

Customer service on twitter had me disable bluetooth.  This let me get full speeds on wifi.  They've contacted LG to figure out how to get both to work at the same time.  It's a bit of a workaround at this point but at least I'm not burning data anymore.

View solution in original post

6 Replies
ryan954
Enthusiast - Level 1

Same problem...

frobert
Enthusiast - Level 1

Same here.

Bobby1927
Enthusiast - Level 1

Customer service on twitter had me disable bluetooth.  This let me get full speeds on wifi.  They've contacted LG to figure out how to get both to work at the same time.  It's a bit of a workaround at this point but at least I'm not burning data anymore.

frobert
Enthusiast - Level 1

Thanks! Seems to work. Hopefully they'll figure it out.

0 Likes
Bartleby
Newbie

Worked for me too. Thank you so much for posting this workaround.

0 Likes
dac595
Enthusiast - Level 1

Disabling bluetooth also worked for me! It's strange this slowness only happens on my home WiFi network, and not other WiFi networks.

0 Likes