Verizon SW Upgrade Assistant Won't Launch
Enthusiast - Level 2

I am trying to resolve a constant rebooting issue on my LG G3 caused by the 5.1.1 update on 10/23.  I want to reinstall the update to see if that corrects the issue as I have tried everything else.  I was instructed by LG and Verizon phone support to use the Verizon SW Upgrade Assistant to "repair" my phone.  I however cannot get the VerizonSWUpgradeAssistantLauncher.exe to install when I connect the phone to my Win7 computer.  When the USB is plugged into the computer, the phone goes into installer mode but nothing autoruns.  I do see the .exe file in windows explorer, click and the circle spins then nothing happens.  The phone then reverts to MTP mode after a short time.  i tried uninstalling the driver but keep having this issue.  Any ideas?  Thanks!

Labels (1)
Re: Verizon SW Upgrade Assistant Won't Launch
Customer Service Rep

We're here for support. Are you receiving an error message of any type on your computer or device?
KleoL_VZW Follow us on TWITTER @VZWSupport If my response answered your question please click the Correct Answer button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!