Phone reboots itself when battery is fully charged

At some point after the Gingerbread update, my phone began behaving erratically.  I used to charge my phone while it was on.  Once it fully charged, I unplugged it from the charger and the battery level would drop anywhere from 5-20%.  If I put the phone on the charger after that, I could charge it back up to 100% and it would stay at 100%.  I had read that the fix for that is to cycle(?) the battery by draining it, turning the phone off, and charging to 100% with the phone off.  When I started doing that, my phone would reboot itself until the battery drained down to below 85%.  The drain usually happened quickly because I tend to lose ~3% of battery by powering on (I'm not so much concerned about that though).  I have had my phone reboot like this before: the phone freezes for a few seconds, the screen goes blank and the boot animation sounds play.  The buttons along the bottom stay lit and the screen stays blank.  The boot animations don't run.  I am running ADW Pro instead of twlauncher.  I have tried uninstalling ADW but the problem persists.  I have searched several different forums, including this one, and I haven't found anything that matches exactly what is going on.  The closest I found was a problem on the Captivate where the phone would freeze and reboot of it went to sleep (as a side note, I set the timer for when the screen sleeps to 20 minutes in the hopes that this would solve the problem and it hasn't). 

I have also tried turning off location services when the phone is starting up.  That worked for a few days but now my phone is in a reboot loop regardless of the battery level.  I am wondering now if the SD card is causing the problems.  Maybe there is something wrong with the card and there is some sort of error when Android tries to read the card?  Has anyone else run into problems like this?  Message was edited by: Arthur Thompson

I appreciate all the help I received on my question, as evidenced by all the replies I received, especially from VZW customer service.  I really appreciate the help (my original post, the first paragraph, was on February 1st).    I think I figured out the problem: many apps had their permissions changed after an update and they lost the ability to be installed on the sd card.  I am wondering if the permission change started creating problems when the program was loaded on the sd card when it wasn't supposed to be able to.  I don't know for certain if that is the cause of the problem, but as I haven't heard anything else from anyone I will go with that.  My phone is working properly again without any bootloops or random restarts.  So...if you are having similar problems to mine, check to see if the permissions have changed that allow you to install your apps to your sd card.  That could be your fix.