Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
Incoming texts turn on the screen, how do I turn that off?
mss47150
Member

As you may know, if you receive a text message, the screen turns on for a brief second, but only long enough to be annoying and then it turns off if, in the split second you reach for it to reply, you don't immediately start texting back. I'd like to turn it off, but none of the options seem to do anything and there are enough options to feel like I don't have 100% grasp on everything. Is this even an option you can mess with?

Many thanks for any replies,

Michael S.

Labels (1)
Re: Incoming texts turn on the screen, how do I turn that off?
tikibar1
MVP MVP
MVP

In the text app, go to Settings > More > Notifications, then uncheck it.  The downside is that all notifications are now turned off, so not only will the screen not light up, but you also won't get your text alert sound nor will the LED light up.

A workaround is to leave the notifications turned off, then install Light Flow (I've always used Light Flow Lite) from the Play Store.  Enable it for MMS and SMS messages with whatever color you prefer for your LED.  You still won't get sound notifications that you've received a text, but you will see the LED light up ... and the screen will stay dark.

0 Likes
Re: Incoming texts turn on the screen, how do I turn that off?
mss47150
Member

I kind of figured it wasn't turn-off-able, but thanks for the other options. I guess the tablet cover will work for this phone, it keeps something to cover it. Thanks again.

0 Likes
Re: Incoming texts turn on the screen, how do I turn that off?
Nyobie_B
Member

There's another option and that is to use a different app for texts. 

There's one on the Market called Contacts+ which allows you to send and receive messages independently from the phone's app.  I found out inadvertently what what you're trying to do is exactly how my phone was working when I loaded this app.  I had Notifications unchecked as tikibar1 mentioned and must have set the Contacts+ app so that it was my main source for sending and receiving texts. 

I just got my phone so I've been working on loading apps and setting this thing up which is taking me several days now due to the large amount of apps I have.  I received a text and noticed that the interface was different than when I first got the phone (before I loaded the Contacts+ app) so I went back in and changed the settings to use the phone's installed app for texting and I changed settings in Contacts+ to no longer use its texting because I prefer the phone's texting app.  There's another that I used to use on a different Android device which I'm still searching for.

0 Likes