Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
Cannot get new phone contacts to save to Google
markslang
Member

Every time I enter a new contact from a phone call, it saves only to the Verizon phone app locally on the phone.  I want to get these new contacts to save to Google contacts so they will sync using Google.  When I try to change the default contacts app, it only lists Verizon Contacts, no option for Google.  I have my Google contacts set to sync, and they do if entered in the Google contacts app.   I can see Google contacts in the Verizon contacts app, but I cannot get the newly entered ones to sync back to Google.  I also have my Google account set as my backup account.  Still, it does not sync my newly entered contacts.

0 Likes
1 Solution

Correct Answers
Re: Cannot get new phone contacts to save to Google
markslang
Member

As I noted, I have discovered a setting when creating a new contact in the Verizon contacts app for Phone or Google in the upper left part of the screen.   Phone is the default.  This has been saving all my added contacts to the local phone only.  I did not even realize this was a menu as it just shows the word Phone in plain black letters.  However, when I click on the word, it gives me the option, instead, to save the new contact to Google.  Once I did that, the next time it seems to still be set to save to Google.  So this is a workaround.   

Google is syncing all contacts created with its app.  However, the phone will not allow me to set the Google contacts app as the default contacts app.  I also gave Google permission to access contacts.  However, for some reason, it does not seem to get the newly created local contacts.   They just stay on the phone.  Fortunately, I only had about a dozen of those local only contacts.  I just reentered all of them in Google, so they are now synced.  The Verizon contacts app does read all my Google contacts, so, once they are in Google, I can use them to make phone calls or send text messages.  So this gives me basically what I need.  However, I don't understand why Verizon seems to have removed the normal Samsung options to Manage Contacts so I could set up Google contacts as the default always without worrying.  I really don't want to use an alternative cloud backup as Google also syncs with my other devices, and that is what I am trying to achieve.

View solution in original post

0 Likes
Re: Cannot get new phone contacts to save to Google
acraftylady2
Sr. Member

You didn't say which phone model.  On my Samsung note 10 plus when I open the phone dialer and go to contacts, manage contacts sync contacts has my Gmail address and it's set to on.  Also in there it says set default storage location and Google is turned on there and not phone.  

0 Likes
Re: Cannot get new phone contacts to save to Google
vzw_customer_support
Customer Support

I like saving my contacts to Google too. I would love to help as much as I can. I do know that the phone does default to save on the device itself. If you want to change it then you will need to go to each contact and edit it. What do you see when you try to make these changes?  AmberF_VZW

0 Likes
Re: Cannot get new phone contacts to save to Google
markslang
Member

Thanks for the advice.  When I open the phone app and go to Contacts, I do not see any way to "Manage Contacts."  I just see the contacts on my phone.  If I select the 3-dot menu at top, I only have settings.  But none of the settings relates to contacts.  I am using the Samsung S6.  If I open a local contact to edit, there is a bar above that says "Phone", and also one next to it that says "Google."  I suppose I could select "Google" and save to copy the contact into Google.  That is a tedious process.

I did discover that, when I select the details of a call and ask to "Create Contact," I have the word "Phone" in the upper left hand corner.  This is actually a menu.  It allows me to select my Google account or Phone if I select it.  That puts the new contact into Google instead -- which is what I want to do.   However, there does not seem to be any way to make Google the default calling  app.  At least the Verizon Contacts app will show Google contacts. 

Perhaps the Manage Contacts feature is part of a new Android version that is not compatible with my older phone. 

0 Likes
Re: Cannot get new phone contacts to save to Google
acraftylady2
Sr. Member

See if this helps.  Maybe older versions you just have to do it one by one. 

https://www.samsung.com/au/support/mobile-devices/how-to-sync-your-contacts-to-your-google-account/

0 Likes
Re: Cannot get new phone contacts to save to Google
markslang
Member

Interesting.  I tried the link you provided for old Android systems.  None of them seems to fit my phone.  I have Android 7.  However, in my contacts app, there is no menu item for "manage contacts" as suggested in the link.  I also don't have the "move contacts to" item listed for Android 6.  I do have a menu item for Verizon Cloud not shown in the examples.  It seems that Verizon has replaced the normal Samsung contacts app with a special version for Verizon wireless phones.  That special version, at least on my phone, does not seem to permit managing contacts, or at least it wants to force you to manage contacts using Verizon Cloud only.  That is a shame.  Pretty poor in my opinion.  That contacts app also seems to be required, as there is no way to uninstall it and try with a new one.  I do also have Google contacts app, but when I try to set it for default it is not even listed in default apps as a possible choice for contacts. 

0 Likes
Re: Cannot get new phone contacts to save to Google
vzw_customer_support
Customer Support

I appreciate your patience with us and I am sorry for the hassle. What model is your Android device? Are all of your apps up to date in the Play Store? 

0 Likes
Re: Cannot get new phone contacts to save to Google
markslang
Member

My phone is a Samsung S6.  The model number specified is SM-G920V.   I have all the apps and the operating system fully updated.

0 Likes
Re: Cannot get new phone contacts to save to Google
acraftylady2
Sr. Member
0 Likes
Re: Cannot get new phone contacts to save to Google
markslang
Member

Thanks for the new link.  Unfortunately, the contacts app on my phone does not have those options.   It seems to be a special version inserted by Verizon.  Since I had not entered too many contacts directly on the phone, I set contacts to show only those on the phone.  I then entered those as new contacts one at a time into Google directly.  Now they are synced.  I am trying to figure out how to avoid that in the future.   I may have found a way to do that since I now know that the "Phone" label in the upper left hand on the screen to create a new contact is actually a menu that will allow me to select my Google account instead.   I just wish they would make it easier to set defaults so we don't have to go to so much trouble.

0 Likes