Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Galaxy S10 will not connect to 4G; stuck at 3G
schke07
Member

After trying all other methods I found on Community and other web sites, I finally found the solution that worked for me.

I went into Settings, Connections, Mobile Networks, Network Mode.

Change from Global to LTE / CDMA.

Respond that you want to select the Network manually.

When the list of networks comes up, click on Verizon.

It will then connect in 4G.

At this point, you can change the Network Mode back to Global.

0 Likes