Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
How do I know if the Samsung Galaxy S7 is using wi-fi calling?
BwwG
Member

Does the Samsung Galaxy S7 have some kind of indication whether it is currently using the WiFi rather than the cell network? I have the phone set up with WiFi Calling enabled with HD voice. But the phone’s lock screen almost always displays “Verizon Wireless” in the top left corner, and the signal strength indicator is one or two bars, i.e. the signal is weak.

I made two calls this morning. The first was to a land line, and was broken up to the point of being unintelligible. (So I called the guy back using my land line.) The second call, just a few minutes later, was to a cell number, and it was perfect.

My WiFi signal strength is good, nearly always the full four bars. (The ability to browse the web on my phone indicates the WiFi is working. It’s a fast 60Mbps broadband cable connection.)

For some reason, the phone doesn't seem to be using the WiFi at times when it should. However, more precisely, I don’t know whether the phone is (a) not using the WiFi, or (b) using the WiFi but unsuccessfully. Hence my question of whether the phone has a way of telling me whether it is currently on the Verizon cell network or on the WiFi.

Would appreciate any advice on this.

Labels (1)
1 Solution

Correct Answers
Re: WiFi calling on Samsung Galaxy S7
vzw_customer_support
Customer Support

We appreciate the great details you've provided. There is not a particular icon that will display according to user manual. Voice calls hand-off from LTE to Wi-Fi when the LTE connection gets weak/is lost and the device is enabled for Wi-Fi Calling and a Wi-Fi network is available. Once the LTE connection is available, the Wi-Fi call automatically hands-off to LTE. Has this occurred with other landlines in the past?
YosefT_VZW
Follow us on Twitter @VZWSupport
If my response answered your question please click the "Correct Answer" button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

View solution in original post

Re: WiFi calling on Samsung Galaxy S7
DigitalRules
Sr. Member

Unfortunately the phone will always prefer a cellular connection until the signal is pretty much non-existent. As you can tell, this is not ideal for your situation. (and many others as well)

Verizon needs to adjust the changeover threshold or incorporate some way to let the user manually switch to Wi-Fi when necessary.

How is call quality if you turn OFF HD Voice at the problem location?

Re: WiFi calling on Samsung Galaxy S7
vzw_customer_support
Customer Support

We appreciate the great details you've provided. There is not a particular icon that will display according to user manual. Voice calls hand-off from LTE to Wi-Fi when the LTE connection gets weak/is lost and the device is enabled for Wi-Fi Calling and a Wi-Fi network is available. Once the LTE connection is available, the Wi-Fi call automatically hands-off to LTE. Has this occurred with other landlines in the past?
YosefT_VZW
Follow us on Twitter @VZWSupport
If my response answered your question please click the "Correct Answer" button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

View solution in original post

Re: WiFi calling on Samsung Galaxy S7
BwwG
Member

Thank you, that does answer my question. One of my big issues here was that, as far as I could ascertain, I was unable to demonstrate WiFi Calling. I didn't see how to make it functional, and even if I did, it wasn't clear how I would know that it was operating.

However, it was actually easy to demonstrate WiFi Calling. Firstly make sure it is Enabled. Then put the phone into Airplane mode, which disconnects the phone from the Verizon network and from WiFi. Then enable the WiFi. I was then able to make calls in WiFi mode, essentially a VOIP configuration. I checked that with WiFi disabled, I could not make calls while in Airplane mode.

At no point in my demonstration was there any kind of icon or other indicator that WiFi Calling was active, which confirms your answer. Thanks.