Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
PLEASE enable Force WiFi Calling as preferred.. not just for roaming!
Phoenix125
Member

I scrolled through hundreds of threads and BY FAR the ones with the most views are "Why can't I force WiFi Calling?"
- Why won't Verizon allow us to use WiFi as the preferred calling option, even when not roaming?  Customers have been asking for it for years.

I provide support for surgeons and need a reliable network. Google-Fi worked perfect but I wanted unlimited data, so I switched to Verizon... what a mistake! In my office, I get 1-2 bars, but my calls often have poor "digital" quality sound and we have a hard time understanding each other.

When I switch to airplane mode and turn on Wifi, my calls sounds amazing, but I often need to leave my office in a rush and have forgotten to turn off airplane mode.  The airplane mode trick is an unnecessary hassle when the WiFi calling option exists and works great, but is disabled for normal use.

Bottom line: If not resolved soon, I'll be forced to cancel my family plan and go back to Google Fi. 

Re: PLEASE enable Force WiFi Calling as preferred.. not just for roaming!
Phoenix125
Member

I should add:
- When I'm in my office, there seems to be a 50/50 chance that my Samsung Galaxy S10e (latest Android 10) will default to WiFi, but the other half, it will use the Verizon network and I end up missing calls occasionally.
- I have WiFi Calling enabled, HD Voice, and WiFi preferred when roaming. There is no option for WiFi preferred (when not roaming).
Thanks!

Re: PLEASE enable Force WiFi Calling as preferred.. not just for roaming!
vzw_customer_support
Customer Support

Phoenix125, being connected nowadays is essential. Especially if you're working with or on the medical field. We're sorry to see you're having such a bad issue with your service, and we would love to check up on this as well, at your most convenient time. However, we want to clear the air about Wi-Fi Calling. This is an exceptional feature that we recommend, particularly if you're indoors and have issues with your service. This feature is absolutely free of charge, but we do need to set it up on the account before it can be used. This process is very simple, since it's a feature we just need to add, and you can activate it as long as you have a connection with our service. Here's a link with our Wi-Fi Calling FAQs: https://www.verizon.com/support/wifi-calling-faqs/ Please send us a private note, if you would like for us to check on your account and make sure the feature is on your account. We will be standing by. 

 

 

IvoneA_VZW

Re: PLEASE enable Force WiFi Calling as preferred.. not just for roaming!
Phoenix125
Member

Thank you for your reply.

I have WiFi calling enabled but the phone reverts back to cellular network and I lose phone calls or cannot understand conversation due to poor digital quality sound.

The simple obvious fix is to allow WiFi calling as the primary/default connection with cellular as the backup for all calls.. not just roaming.  Sprint, T-Mobile, AT&T, Google-Fi, etc all have it. Android does this by default but Verizon purposely disables WiFi calling as the preferred connection method. It seems foolish since this is a high demand feature requested by customers.

As stated, my cell reception in my office gets 1-2 bars. I kept my phone in same spot on my desk. Today, my phone defaulted to Cellular calling for my first (outgoing) call. I hung up, turned on Airplane mode, then WiFi.  My call sounded great.

For testing, I turn off Airplane mode. My next two calls remained on WiFi and sounded great.

The next call reverted back to the cell network.  I noticed immediately because the conversation had digital garbage sound and I lost audio occasionally.  I had to hang up and reconnect after doign the airplane mode workaround.

My biggest concern was a missed call because the cell reception wasn't good enough for the call to go through, but not poor enough for the WiFi calling to kick in.

Other than this issue, I am happy so far with Verizon.  But I need a reliable connection. I had that with Google Fi's WiFi calling. I COULD have it with Verizon, but your company disables the one thing that would resolve my connection issue.

Re: PLEASE enable Force WiFi Calling as preferred.. not just for roaming!
vzw_customer_support
Customer Support

Let's take a closer look in to this issue for you. To authenticate your account please confirm your first and last name, review the following, and then click the link after "Authenticate here":

If you use Messenger or Direct Message to chat with Verizon, your questions and our responses may include info about your account, including Customer Proprietary Network Information (“CPNI”), which is visible to Facebook/Twitter and may be used for their own purposes per their privacy policies (http://spr.ly/6608Gwfky / http://spr.ly/6609GwfkJ).

CPNI is info available to Verizon solely by virtue of our relationship with you that relates to the type, quantity, destination, technical configuration, location, and amount of use of the telecommunications and interconnected VoIP services you purchase from us, and related billing info.

Verizon protects your info and does not share info that identifies you personally outside of Verizon except with your consent and as otherwise disclosed in our privacy policy. Your choice here does not affect your Verizon services. To learn more, visit our information collection and privacy policy at http://spr.ly/6600GwfkK.

By clicking the link to continue, you agree to allow us to share your info, including CPNI, in Messenger and Direct Message. To stop sharing info including CPNI, stop using Messenger and Direct Message to chat with us. Contact Facebook and Twitter about your rights, if any, to delete info that was previously shared.

Authenticate here: http://spr.ly/6002GwfX2.  CassieG_VZW

0 Likes
Re: PLEASE enable Force WiFi Calling as preferred.. not just for roaming!
Phoenix125
Member

By the time I tried the link, it expired.

Update: The phone seems to remember my last preference. If I do the Airplane mode then enable Wifi work-around, it seems to retain that preference until it connects to a Wifi that requires logging in via a web page, such as at some restaurants, therefore making the Wifi connection unusable until I log in.

Although I'd prefer full control over Wifi calling, I am OK with this. My Samsung Galaxy S10e seems to use the Wifi calling at work and home now until I visit the same restaurant that required logging in via the web page.  Afterward, I just have to redo the Airplane mode/enable work-around Wifi at home and at work.

Thank you.

0 Likes
Re: PLEASE enable Force WiFi Calling as preferred.. not just for roaming!
Carm-0
Member

I am going to shed some light on this problem as I too have this problem and there are ZERO solutions from any Verizon customer service rep because they are left in the dark on the matter and upper management thinks it is fun to have customers jump through a bunch of nonsense hoops for a problem they are creating for their users and do not want to admit they are causing and wasting their customers time.

What I do not want some CS rep telling me how important it is to stay connected, or lets look at your account garbage. THERE IS NOTHING they can do.

This is a Network policy that Verizon Wireless forces out to ALL their customers. In a nut shell it says as long as you have any cell signal DO NOT USE WIFI CALLING. This is even to the point of barely registering  any cell signal. This is nothing more than a draconian policy designed to be anti-customer friendly. The do not tell the customer service reps about it. They are 100% in the dark.

There was an adb ( android command line ) that could enable it and I have used it, however Verizon Wireless requested Google to disable it in Android Pie( there is an XDA post about this somewhere with a commit in the google code stating this).

If you pop another SIM card in for TMO for example then you have the option.

By the way this goes not only for Calls but text messages as well that you might not be able to send as I have been experiencing. There is NOTHING ANY tier one or two level REP can do , and I doubt anything Level three would do since this is some draconian policy that they push out for some reason. I nor anyone else has been able to git a clear answer as to why Verizon Wireless hurts their customers experience like this. The only thing that makes any since is that giving the customer the option of using WiFi preferred makes it seen their network terrible which as far as coverage area it does not.

The second half of the problem is phone manufacturer caving into these companies allowing them to control these features that are trivial at best.

I am going to write my congressman as that would be the only way to force Verizon to provide an answer. The other thing is just to have people hound them as to why they are forcing this network policy, or a class action. I do not have some of the XDA posts on this but the reddit one speaks loud

https://www.reddit.com/r/verizon/comments/9at4ea/why_why_why_verizon_why_is_wifi_calling_so_elusive/

Re: PLEASE enable Force WiFi Calling as preferred.. not just for roaming!
vzw_customer_support
Customer Support

I am sorry to hear all you been through as it relates to your signal issues and your Wi-Fi calling problem, Carm-0 I want to do my best to help out based on what you shared. However, I need to gather more information as I am sure what exact troubleshooting steps you've tried to work on this issues. What is the make and model of your device? What is your city, zip code and closest intersection?  We can check the area with our coverage map and check if there are any known service issues being reported. As far as Wi-Fi Calling, did you set up and initially being on our network? This is a good option If you're indoors and have issues with your service. This feature is absolutely free of charge, but we do need to set it up on the account before it can be used. You can activate it as long as you have a connection with our service. Here's a link with our Wi-Fi Calling FAQs: https://www.verizon.com/support/wifi-calling-faqs/

 

Thanks,

Edwin_W 

0 Likes
Re: PLEASE enable Force WiFi Calling as preferred.. not just for roaming!
jcalabria
Member

Exactly this!  My house has barely acceptable reception outdoors, marginal indoors and almost non-existent in my basement office (where I work full time).  Normally, the phone will be in Wi-Fi calling mode when I'm in the office, but occasionally it will get a whiff signal and revert to 4G calling.  If the phone rings while it's in 4G mode and I pick up the call, the call will either be dropped or the call quality will be unacceptable once the phone is moved even a few inches. 

On my S8, I was able to consistently force wi-fi calling by turning off mobile data when I was at home, but this brought on additional issues such as no voice mail retrieval when in Wi-Fi mode as well as needing to remember to turn mobile data back on when I leave the house. 

On my new S21 5G, I have a new additional problem in that WiFi calling will not activate by turning off mobile data as it did in the S8... it essentially leaves the phone with no phone service until you reboot the phone while mobile data is deactivated, in which case WiFi calling will then work.

It's absolutely unacceptable that WiFi calling cannot be forced as preferred mode when in marginal signal conditions.

0 Likes
Re: PLEASE enable Force WiFi Calling as preferred.. not just for roaming!
vzw_customer_support
Customer Support

To ensure the right settings are in place, jcalabria, in Settings > Connections > tap Wi-Fi Calling. What is Roaming network preference set to at the moment? 

0 Likes