Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
World Clock - Always On Display doesn't work when roaming for S8+
hansangb
Member

So with my S8+, at home (US Eastern), the three other cities that I added show up on the AoD screen. However, when I'm roaming, AoD will *not* show the World clock. I can choose any other clock option and it will work. However, World Clock does not.

If you travel a lot this is an incredible time saver.

I tried changing the "Content to Show"

I tried changing Information and FaceWidget - Roaming Clock (on or off), tried changing the home time zone.

On my S7 Edge, the "Home Time zone" never worked. But it was OK since the first clock on the World Clock was the current time zone.

I also tried changing the Date and Time, from auto to manually adding the local time zone.

I called tech support but she had no idea what I was talking about. She wanted me to add the cities in the Clock app (works just fine). But I'm talking about the World Clock under Always On Display.

Help!

thnx

hsb

Labels (1)
0 Likes
Re: World Clock - Always On Display doesn't work when roaming for S8+
vzw_customer_support
Customer Support

Making sure you can keep track of the time when you travel is a must, hansangb. This feedback is incredibly helpful. Let’s see what we can do to help. What happens if you place the phone in safe mode? You can place the phone in safe mode by following these steps: https://www.verizonwireless.com/support/knowledge-base-211218/

JosephE_VZW

Follow us on TWITTER @VZWSupport

If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Re: World Clock - Always On Display doesn't work when roaming for S8+
hansangb
Member

OK, it looks to be a weird bug.  To recap: 

1) It worked at home (US Eastern).

2) Flew to Olso where it didn't work. So I assumed it wasn't working because I was roaming internationally. 3) 3) Then the next day (no change to the phone settings) I flew to Stockholm where the world clock/AoD *worked*.

4) Then two days later I flew to Oslo again. (no change to the phone settings)  And World Clock/AoD stopped working again.

0 Likes