SIM Card Issue (Refreshing SIM Data)
SekcyOnee
Newbie

Hi;

I'm having troubles with my SamSung Galaxy S3. It is a problem that has been happening for a few days now.

A little message will pop up every 5-10mins stating; "Refreshing SIM Data" When this message pops up

I loose connection to everything, Mobile Internet, WiFi, Music, Videos, Pictures. etc. Pretty much everything on me phone.

I've tried to look for a problem resolver using my phone but whenever I'm just getting to the problem I loose everything

cause of the stupid "Refreshing SIM data" thing pops up.

Is this a problem with the SIM card? or is there a setting on my phone I can stop this from happening.

Or might it be a problem with my phone?

If I can get a responce to this ASAP it would be very very helpful thank you very much!!

Labels (2)
0 Likes
35 Replies
expatchic
Newbie

Omg! This issue has been driving me nuts since I received my Samsung TABLET about three weeks ago. I was traveling overseas, and chalked it up to a weak signal.  When I got back to the US, I was using the 4G network, so didn't really get to test it.  However, it seemed stable enough in the airports.  I'm now overseas again, and experiencing  the same ANNOYING problem, despite the fact I'm literally sitting under the router.  However, the bandwidth is small and is shared, so I'm sure that has something to do with the problem.  HOWEVER, both of the solutions outlined below seem to "fix" the problem: 1) set the network to LTE/CDMA, but suffer the annoying 'switch to Global' message.  2) Turn on airplane mode, then manually turn on the WiFi (and Bluetooth if needed).  This fix has allowed me to actually complete this message!  I don't think it's a Verizon issue, but perhaps a Samsung issue?  To me, it seems the WiFi is constantly scanning, and reconnecting to the best network connection.  Anyone know how to make it stop scanning?

Regards.

0 Likes
Ronich
Enthusiast - Level 2

To everyone with the low signal problem...

I've just bought the Wilson Electronics Sleek 4G mobile signal booster. I can see about a 4db gain in the signal. It's just enough to complete ALL calls, texts, and internet connections.

I highly recommend.

0 Likes
Squirrel_WNY
Enthusiast - Level 1

I'm running 4.1.2 now on my Galaxy SIII and it's still doing the same thing.  For me, it doesn't matter whether or not I'm using wi-fi.  It's totally dependant on my cellular signal.  When the signal drops, it starts doing it.  It does it just like everyone else says - approx. every 3-5 minutes or so.  It doesn't stop until I'm back in signal again.  And of course, every time it happens, it dumps whatever I was working on (or playing).  It's extremely frustrating, considering I only have the network in certain areas in my home, and it's even worse at work.  I will try the airplane mode mentioned above and see if it also helps my phone.

Just my luck...I finally find a phone I really want, spend the big bucks to get it, and it's currently one of the most frustrating phones I've ever had.

VERIZON and SAMSUNG - PLEASE FIX THIS ISSUE!!

gf1fanatic
Enthusiast - Level 1

The airplane mode option will still fix the problem, but this is ridiculous! No wonder people buy iPhones! Samsung and Verizon should be ashamed of themselves! These are billion dollar corporations and they let something like this happen. They really care about their customers, don't they!

dnoreen
Enthusiast - Level 1

I bought a new phone, will sell my Verizon phone in the US and chalk it up

as a lesson learned. Never going back to Verizon and will advise others to

do the same.

0 Likes
squarepegjer
Enthusiast - Level 1

Just updated to Android 4.1.2 today - and so far, I haven't seen the problem come up. We'll see if this is the fix or not!

0 Likes
vzw_customer_support
Customer Service Rep

Squarepegjer, I'm excited to learn that you recently recieved the Android update on your device. I trust that the new features and bug fixes will improve your wireless experience on your device. Please keep us posted and feel free to reach out to us if you need any assistance. We're here for you.

Lasina_H
Follow us on Twitter @VZWSUPPORT

0 Likes
s10stealth
Enthusiast - Level 2

Why is Verizon Customer Support's ONLY comment is a congratulations and mentions NOTHING about the problem on this blog?

0 Likes
vzw_customer_support
Customer Service Rep

Dear s10stealth,

I apologize our previous response was not helpful. Allow me to help provide some resolutions to fixing your equipment concerns. When you get the refresh sim data message, are you in a certain location? What zip code are you in?

I personally have the Samsung Galaxy S3 and have not had this error pop up on my phone. Can you try removing your sim card, then re-insert it back to your phone. To learn how to remove your sim card click http://vz.to/109THr2. Please keep us posted if this has helped.


Thank You,
MichelleS_VZW
VZW Support
Follow us on Twitter @VZWSUPPORT




0 Likes
dango
Newbie

i just started having this problem today. i live in yellowstone, and i got verizon under the assurance that i would have service here. in other parts of the park i do, but not where i work. my employer provides wifi in our dorms, but it is essentially useless now that this has started happening. even more frusterating is that i can't call, and the only other options are to send a letter in the mail, or look for it in an open forum. for what i pay a month on a service i can't use i should be able to at least send an email, or "chat" with a rep. i couldn't even find a place on the website to report this as a problem.

ranting aside, turning it off and back on did nothing. removing the sim card for a minute did nothing. the airplane mode thing mentioned in a previous comment did nothing. changing the network settings did the same thing as the others who had tried it. it would be worth keeping verizon if i could at least skype, facebook, and email until the cell tower scheduled to be erected is up. (last i heard, november... ish)

0 Likes
Ronich
Enthusiast - Level 2

The one thing I can't figure out is if it's a...

"low signal Verizon thing" or a

"Samsung Galaxy S3 sensitivity thing" or a

"Jelly Bean signal processing thing"

0 Likes
s10stealth
Enthusiast - Level 2

The problem seems to be with a low signal. When the cell re-connects to a tower from being in a "no mobile network found" condition, it seems to trigger the error.

I'm on day 4 of my newly exchanged S3 and I noticed the same "refreshing SIM data" problem.

I'm not happy to set that my "new S3" is merely a refurbished unit. It defeated the purpose of verifying a hardware issue.

Roger

0 Likes
kevind1986
Newbie

I have the same problem i am only on WiFi and it will close me out of everything. This is a Verizon Issue.

0 Likes
78RPM
Enthusiast - Level 2

I don't think Verizon caused it - but it seems to me they should have taken the bull by the horn and done something (anything) about it.

It didn't happen on the the SIII until the Jellybean upgrade - that's Google.

It seems to happen only on Samsung devices - that's Samsung.

Do this/No do that/factory reset/sim cards replaced/nobody's ever heard of that before/you tried that already? well, try this then/that didn't work, well bummer for you/global this lte that...Arrgh!

That's all Verizon!

0 Likes
Illumaone
Enthusiast - Level 1

For what its worth I too have this Horrible annoying problem when at work were the signal is poor.

0 Likes
squarepegjer
Enthusiast - Level 1

My wife and I are both having this same problem, on Galaxy SIII's... and only after updating to Jelly Bean. HORRIBLY annoying.

It happens when the mobile data signal appears / disappears. Which is CONSTANTLY because we live in an old brick & masonry building with next to zero signal. Gotta love it - pay top dollar for a new phone, pay more for the new, no-unlimited data plan, then have to pay double to have a land line installed because the cell phone doesn't work indoors, and now when I'm using WIFI (from another company, because Verizon doesn't service half our town) my phone glitches out and cancels all of my work.

Tried forcing it to LTE networks - doesn't give the 'refreshing sim data' message, but it pops up with the 'switch to global?' message. Almost as annoying.

VERIZON & SAMSUNG - could either of you please read these forums??? This one little glitch could cost you a ton of customers.

gf1fanatic
Enthusiast - Level 1

A Verizon rep has admitted to me that they are aware of the problem, but are unable to find a fix. Hmm? Maybe I could tell them I'm unable to find the money to pay my monthly bill. Anyway, as someone else has posted, for now a good workaround is to turn on airplane mode and then manually turn WiFi on. This has fixed the problem for me when I am in a poor data signal area, such as in my home.

And where is Jelly Bean 4.2!!?? Do Verizon and Samsung really care about their customers? Doesn't appear so.

Gail123
Newbie

Just talked with Samsung. They said only option left since factory reset didn't work is for me to send phone in for repairs. This problem has not been reported enough to them to be considered as 'a problem'. THIS ISSUE NEEDS TO BE REPORTED TO SAMSUNG DIRECTLY. Please report to them so they will be able to get on this problem. Thanks! 

0 Likes
78RPM
Enthusiast - Level 2

Too bad a company the size of Samsung doesn't have access to Google. If you put that error message in it comes up all over the place. Since they're all specific to Samsung I have to think it has to do with their implementation of Android. Actually, I'm pretty sure with my S3 this didn't start happening until I was upgraded to JellyBean, I'm very disappointed with Samsung over this and I'm on my 6th Samsung phone, so I was a pretty happy customer before. Right now the phone is mostly just annoying when I'm in my house (no signal) and trying to use it with wifi. And before this started happening I was very happy with my S3.

Verizon's not exactly stepping up to the plate on this and going to bat for us either. Kind of shameful on all their parts really.

sweetjonnycrash
Enthusiast - Level 1

I had the same problem with my note 2..I found a workaround which worked for me. I turn airplane mode off then turn wifi back on. Not the best fix but proof it has something to do with the radio signal with wifi.