Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
Showing results for 
Search instead for 
Did you mean: 
Stuck on Android 4.0.3. NO Jelly Bean update 4 me!

Hi everyone.

Folks, I'm feeling like I'm missing something... really. I'm 100% noob in all Android stuff (please remember that, I don't understand all that complicated android terminology), so here what I got. Verizon Galaxy Nexus 4G LTE. I bought this smartphone from a friend of mine, it wasn't rooted (or how do you call that things?) or anyhow modified. I didn't do anything with it also, therefore smartphone is the same as it was when it was bought from Verizon.

As far as I can see, I was supposed to get update for Jelly Bean. But still there is no update. I still have android version 4.0.3. That's quite strange, don't you think so? I've tried famous trick with Google Services Framework many-many times, nothing. I tried to switch between WiFi / 3G/ LTE, restart / clean data / force stop / visa versa & do all the things that were supposed to help force upgrade, still nothing. I tried some codes with symbols like  *# to force update (don't remember the exact code), not working.

Folks, can anyone explain me without complicated details how to get the Jelly Bean? I don't wanna root the bootloader, download and manually install something and do that crazy stuff with my device. I just want the update to come 🙂 Can anyone help? Sorry for beeing such a noob and typos, English is not my native language. Happy holidays everyone )))

When I go to "Settings - About phone", what I see is:


Model number: Galaxy Nexus

Android version: 4.0.3

Baseband version: I515.10 V.EK06 / I515.EK04

Kernel version: 3.0.8-g49a0ff3 android-build@apa28 #1

Build number: IML74K


When I use application "Android System Info" and go to "System - BuildInfos" what I see is:


Android version: 4.0.3

Release Codename: REL


CPU ABI: armeabi-v7a

Manufacturer: samsung

Bootloader: PRIMEKL01

CPU ABI2: armeabi

Hardware: tuna

Radio: unknown

Board: tuna

Brand: google

Device: toro

Display: ILM74K

Fingerprint: google/mysid/toro:4.0.3/IML74K/239410:user/release-keys



Model: Galaxy Nexus

Product: mysid

Tags: release-keys

Type: user

User: android-build


Re: Stuck on Android 4.0.3. NO Jelly Bean update 4 me!

<Comments deleted per the .> It's really annoying (and makes me wanna sell the device & switch to any other carrier just on principle) to hear "please_wait_for_update_patiently_it_will_be_delivered_soon" in Verizon stores every time I come there to ask when I'll get the update.

Message was edited by: Verizon Moderator

Re: Stuck on Android 4.0.3. NO Jelly Bean update 4 me!

I really hate to suggest this because it should not need to be done, and it'll wipe your phone, but have you tried a factory reset?  I know that *might* do it but only at the cost of clearing out all your data and apps.  Once done you *should* get the update notifications.  You may want to ask on other forums like xda-developers.

Re: Stuck on Android 4.0.3. NO Jelly Bean update 4 me!

Factory reset didn't help. But I followed your advice about XDA-Developers and yes, that was the best idea from the beginning, so thank you for that so much Smiley Happy

Turned out that that my Galaxy Nexus belonged to one of the Google workers and the most important thing is that this folks got their Galaxy Nexuses with some crazy Android version (for developers or something like that) - this is the main reason why my device didn't get the update. And there is no chance that it would ever get it, because technicaly speaking such thing as Android 4.0.3. doesn't exist (at least for the market).

So, the only chance to get the update is to (1) unlock the bootloader, (2) install Google's official 4.0.4 android version (factory image), (3) check for the system update and, finally, (4) get the 4.1. update, directly through the smartphone's system settings.

p.s. turned out it was not that hard as I thought. everything was done using 1 program, GNex Toolkit V10.1.