Unable to Connect Authentication Error
Enthusiast - Level 1

I am devastated. I noticed in August my Galaxy S9 would not start the mobile hotspot, a feature I need as I am a traveling person who is a web developer.

They said it was going to be fixed in the next update. NOT! last week I went to use the Hotspot, and same error as the title of this post (Unable to Connect Authentication Error).

I called and after bout an hour of fudging with things they said they were going to send me a completely new phone - a Galaxy S10e - well guess what!?? SAME ISSUE after all the hours of pleading with Verizon and the total inconvenience of waitying for the new phone and setting it up again with all my apps, wiping my old phone and getting this error again, is enough to make me lose my mind. 

I wish I had tested the HotSpot BEFORE i wiped my old phone 

This is telling me it is indeed NOT a hardward issue but something wrong with my Verizon account!

I am about to eat the contract and switch to another provider after being a dedicated Verizon custonmer for over 10 years.

Labels (1)
3 Replies
Enthusiast - Level 1

I have had the s10 plus for a few months and noticed when I first purchased the phone the hotspot did not work. I forgot about it as I don't use it often but just went to try to use it tonight and am still getting the same error. As a Verizon and Samsung customer for many years I find this problem very disheartening, it appears to be many people with the same issue and no one caring enough to fix it. Definitely not planning to upgrade anymore to the s20 as it seems to be an ongoing issue, might be time to look for a new provider if Verizon cant fix something like this.

Customer Service Rep

Hello there, cindyi! It's our priority to provide a seamless network experience and we are concerned to hear that you are experiencing challenges with your Mobile Hotspot. We would love the opportunity to help you in any way we can. Can you tell us a little more? When was the last time you were able to use the Mobile Hotspot? 




 I was having this same problem, getting "Unable to Connect, Authentication Error" and "Try to connect later" message, every time I tried to enable my Galaxy S10e's mobile hotspot feature. I restarted my phone, uninstalled unused app's, cleared all the temporary files on my app's cleared the cache in my most used app's, trying to free up space in my phone's memory. This seemed to work, but to my frustration, only RIGHT after I did it. (It only worked to turn it on, that one time, then the next day...same error, AGAIN!)  I remembered I had enabled my "Developer Options" at one point since owning the phone, so I turned this off and tried again....LOW & BEHOLD- hotspot feature IMMEDIATELY turned on with NO issues! 

Now I don't know that it will continue to connect, but wanted to share my solution, however temporary....