Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Wifi Problems since Froyo OTA upgrade
efficiondave
Member

I upgraded to Froyo on the day it was released (several months ago). Ever since then, I've had consistent problems with Wifi. My phone connects fine and shows a good strong signal, but things are incredibly slow or non-functional (though for the first few seconds of use, sometimes it fast).I usually end up turning off Wifi and just using Mobile Data as its much faster and more reliable and my battery lasts much longer.

 

Many other devices connect to my wifi without issues. I've got high-speed DSL that we use constantly without issue. I've tried connecting to several other wifi networks and have the same problems. I've hard reset the phone several times. I took my phone into a Verizon corporate store and they fiddled a bunch but it made no difference. I had Verizon replace my Fascinate with a refurbed Fascinate over a month ago but the "new" phone has the exact same problem. I've upgraded all the software on the phone to the latest version (just upgraded to ED05 tonight and it made no difference).

 

Otherwise, my phone mostly seems to work well.

 

It doesn't look like many other people on the forums are having this issue. Anything else I can try?

 

David

0 Likes
1 Solution

Correct Answers
Re: Wifi Problems since Froyo OTA upgrade
efficiondave
Member
I was finally able to resolve this issue by changing the security on my router from WPA2 to WPA(tkip). The router I have is a NetGear.

View solution in original post

0 Likes
Re: Wifi Problems since Froyo OTA upgrade
Herbb623
Novice

Well first thing to try would be to delete/remove all your current wifi connections.

Turn phone off. Remove battery for couple minutes.  Put battery back in.

Turn phone on.  Add your wifi settings/information back in again.

 

If that doesnt help, then since you just installed ED05 update, a factory data reset

'may' help. 

Menu...Settings...Privacy...Factory data reset..

( Make sure your contacts, calendar, etc are backed up first. )

 

After resetting, add in your wifi settings and test PRIOR to installing any apps

from the Market.

 

Not sure what else to try.  Good luck.

0 Likes
Re: Wifi Problems since Froyo OTA upgrade
efficiondave
Member

I went ahead and tried doing the remove, power off, remove battery, power on, add approach. No change.

 

I've reset the phone(s) 3 times since this started happening. I'm not willing to try that again with the very remote chance that it will work now because of the ED05 update. I really don't have many apps on the phone and what I do have are very standard (Facebook, Twitter, Angry Birds, Google Maps, Google Navigation, Google Places).

 

Changing out the phone makes it very unlikely that this is a hardward issue and so it must be a software issue. I would guess a lot of people are having this problem and just haven't reported it here.

0 Likes
Re: Wifi Problems since Froyo OTA upgrade
sevendaysout
Member

I'm having the same issue.  I get 4kb down (yes that is 4kilobytes) and about 40k up on WIFI.  I am 6 feet away from my Netgear WNR3500v2 gigabit router.  On the Droid x I am connecting as N.  I have a laptop right beside it that gets 25mb down and 1.5mb up on both N and G connections.  

I didnt see this problem before the recent upgrade to 4.5.602.MB810.  I could only assume that this is a software bug that was included in that update.

0 Likes
Re: Wifi Problems since Froyo OTA upgrade
efficiondave
Member

@sevendaysout the problem I'm having is with a Fascinate, since it sounds like you're using a Droid X, I doubt it is related.

 

However, I was curious about how you were measuring you up/down speed. I went ahead and downloaded an App from SpeedTest.net and ran it a few times:

 

1st Run: Wifi Off, Mobile Data On: Ping 111ms, Download: 1030 kbps, Upload 541 kbps

2nd Run: Wifi On, Mobile Data On: Ping 69 ms, Download 1788 kbps, Upload 4kbps (and it hung at 2% complete for a long time)

3rd- 6th Run: Wifi On, Mobile Data On: Network Communication Issue

 

Started Typing up this message and tried the test again after a couple minutes

7th Run: Wifi On, Mobile Data On: Ping 68ms, Download 1722 kbps, Upload 9 kbps (hung again a 2%)

8th Run: Wifi On, Mobile Data On: Ping 69ms, Download: 1791 kbps, Upload 9 kbps (stuck on several spots)

 

So, it does seem the problem is uploads. I'm guessing the Network Communication Issues were it wasn't even able to send out the bits needed to get the test going properly.

 

Turning Mobile Data Off makes no difference.

0 Likes
Re: Wifi Problems since Froyo OTA upgrade
Herbb623
Novice

Well,  I got just as curious about my Fascinate's speed as well.

 ( its running Froyo stock ED05.. I did do factory reset after installing ED05 ).

 

Downloaded and installed speedtest.net.

 

Mobile ON WiFI OFF:   Ping  140     Download  934k    Upload   846k

 

Mobile OFF  WiFi ON:   PIng  40     Download  22,200k    Upload   4,130k

 

Mobile ON   WiFi  ON:    Ping  41      Download   21,500k    Upload   4,000k

 

Ran above tests multiple times all with very similiar results.

Wifi is via comcast cable modem at my house.

 

General usage of the phone bears out above results.  When i'm in range of WiFI,

I turn it on and get much better results than over Mobile data, as expected.

 

 

0 Likes
Re: Wifi Problems since Froyo OTA upgrade
DionM_VZW
Verizon Employee

efficiondave wrote:

I upgraded to Froyo on the day it was released (several months ago). Ever since then, I've had consistent problems with Wifi. My phone connects fine and shows a good strong signal, but things are incredibly slow or non-functional (though for the first few seconds of use, sometimes it fast).I usually end up turning off Wifi and just using Mobile Data as its much faster and more reliable and my battery lasts much longer.

 

Many other devices connect to my wifi without issues. I've got high-speed DSL that we use constantly without issue. I've tried connecting to several other wifi networks and have the same problems. I've hard reset the phone several times. I took my phone into a Verizon corporate store and they fiddled a bunch but it made no difference. I had Verizon replace my Fascinate with a refurbed Fascinate over a month ago but the "new" phone has the exact same problem. I've upgraded all the software on the phone to the latest version (just upgraded to ED05 tonight and it made no difference).

 

Otherwise, my phone mostly seems to work well.

 

It doesn't look like many other people on the forums are having this issue. Anything else I can try?

 

David


Greetings to all community members. Thanks so much for your amazing feedback on this issue!

 

Hi David! I'm here to help with your WiFi speed issue. Looks to me like you've done a lot of great troubleshooting, all of which fits just right with the recommendations I would have made. I do have another recommendation, though. I 'm curious to know what up & download speeds you get using a different WiFi emitter. Have you ever used a public WiFi to see if the speeds are the same as your private device? Many restaurant chains now offer free WiFi. I'm also curious about something. Most smartphone owners that are interested in WiFi do so to avoid exceeding their data limits, but your user profile indicates that you have the $30 unlimited data plan.  I was wondering what attracts you to WiFi when you have unlimited data. Thanks in advance for your feedback!

0 Likes
Re: Wifi Problems since Froyo OTA upgrade
efficiondave
Member

I connected to a friends wifi connection this weekend and was able to get much better upload speed:

 

1st Run: Ping 227kbps, Download: 1529kbps, Upload: 364kbps

2nd Run: Ping: 227kbps, Download: 950kbps, Upload: 290kbps

 

I'm wondering if it could be a problem with Wifi N (my router) vs. Wifi G (my friends router)

 

As far as why I prefer Wifi over 3G, it's about speed and reliability. Wifi should be significantly faster and more reliable than 3G.

 

David

0 Likes
Re: Wifi Problems since Froyo OTA upgrade
DionM_VZW
Verizon Employee

efficiondave wrote:

I'm wondering if it could be a problem with Wifi N (my router) vs. Wifi G (my friends router)

 


Entirely possible! Interconnectivity between your phone and router can also be affected by materials used in the construction of your home, other devices in your home. Admittedly, it's tough to say. But at least you know that your phone is capable of WiFi connection, and that it is capable of faster up and down speeds!

0 Likes
Re: Wifi Problems since Froyo OTA upgrade
efficiondave
Member

BUT, It's not a connectivity problem, my phone shows the appropriate number of bars based on my proximity to the router. When I'm close, I have 4 bars (full connectivity), when I'm far away I have 0-1 bars. The problem exists regardless of whether I have 1 bar or 4 bars. And, it worked fine before the Froyo update. It's not a connectivy issue. It is a software problem.

 

I will try to verify that the problem only occurs when using an N connection, but you're not off the hook, this is still a real problem.

0 Likes