Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone. OR get iPhone 13, on us for a limited time. Online only. With Select 5G Unlimited plans. Buy now
end of navigation menu
DVR web remote access
Enthusiast - Level 1

How do I activate my table top DVR so I can access from the web to record programs

Re: DVR web remote access
Contributor - Level 2

Hello videojim,

With your Fios remote hit menu>settings>remote dvr access

Re: DVR web remote access
Enthusiast - Level 3

Good luck with that one VideoJim. In the three months that I have had FiOS TV, I have only been able to access the DVR's remotely maybe three times. Most of the time they do not respond or time out. Before I replied here, I tried again and just got and error that says... "Attention! There was an error while processing your request. Please try again later."  Of course the show I want to record is in 15 minutes. You can call tech support and they will tell you to reboot your router and reboot your set top boxes, but that doesn't work if you are not home and the show you want to record is something important. 

Re: DVR web remote access
Super User
Super User

Yeah ... I have this problem too.   I can never seem to manage the DVR from the Verizon Web portal.   I also have the Remote DVR app on my iPhone and it works great -- never an issue.

So, I did some poking around on the router -- went into the Firewall and then into the Security Log and turned on some debugging to look for blocked packets and such.   Took a look at the current Firewall rules (port forwarding) and noted that each of my boxes has an inbound port mapped for port 8082 in the port 35000 range ... and one box has a mapping for port 63145/UDP.   I figure this one must be the DVR box -- that port is likely the remote DVR function.  I note that it's mapped to the box on IP

OK ... so I try from the web.  No dice.  No denied packets in the security log.

Now, I try from my iPhone ... wait a bit but finally goes thru ... works.   Look at the security log -- all clear.  Look at the port forwarding log -- and what's this?   Everything is the same except for one rule -- the port forward for 63145/UDP now points to the box on!

OK ... back to the web portal.   Try again.   Hey ... it works!

Went and checked the DVR STB ... sure enough, it's IP address is

So, the problem appears to be that the port forward that gets added to the router (dynamically using the uPNP stuff when the STB first boots up.  Some time later when the DHCP reservation expires, the box moves to a new IP and in the process the port forward does NOT get updated.

Resetting the box (or perhaps more correctly the modem), probably clears the port forwards and if you do it in the right order (All STB's unplugged, router unplugged, router booted, DVR booted, other STB's booted), I bet it sorts itself out and it works for a while.   If not, doing a reset on the router instead of just a power cycle in the previous sequence should certainly do it.

So... how to fix this permanently? 

OK ... here's what I'd try.   Do all the steps I outlined above and get the remote DVR stuff functioning.   Note the IP address of the DVR STB (find it in the port forwarding on the router or get it from the System Settings menu on the STB itself).  Once it's working, go into Advanced Settings -> IP Address Distribution -> Connection List.   find the IP address of the DVR STB and choose the "Edit" icon under the Action column.   On the next screen, check the box which says "Static Lease Type" and hit Apply.   

Now, the DVR STB should stay on the same IP all the time  (don't change the IP address -- it needs to stay in the low 100 range since Verizon applies some QOS to the STB's to insure they get priority over internet traffic for streaming content).    Your port forward should also stay put as well and if it does, your DVR remote access should continue to function.

I only did some quick testing with this just now and it appears to be working.

Re: DVR web remote access
Super User
Super User

Oh ... if you followed along and turned on logging in your router ... don't forget to go back and undo it.

Re: DVR web remote access


I have been using remote DVR pretty much since it first became available, and it almost always works for me. Yes, I have had a few occasions where it didn't, but very few. And the IP address of my DVR has rarely changed; I just checked, it is right now, has been for months. And I haven't had a failure for months.

Now, I think you have probably hit on the "what", but I don't understand the "why", so I am hoping you can explain.

1) Why would the local IP address of the DVR change? The only reasons I can think of are:

a) I disconnect the DVR from my network long enough that the DHCP license of one of the other STBs expires, or I connect a new STB, and it gets the DVR's old IP address.

b) I reboot the router and the STBs ask for IP addresses in a different sequence than they did the last time they asked.

As long as the router stays up, and the STBs are all connected and have IP addresses, one of them reaching the end of their lease and requesting a new lease will always wind up getting the same one won't it?

2) Why did the remote DVR access via the web fail to update the rule but apparently the iPhone access did? From your description of what you did, that appears to be the only thing you did that caused the rule to change to the correct IP address. And back to my question #1, why had the IP address changed to start with?

Inquiring minds want to know...... Smiley Very Happy

Verizon FiOS TV, Internet, and phone
QIP6416-P1, IMG 1.7.1, Build 09.97
Keller, TX 76248

Re: DVR web remote access
Super User
Super User

Your right about the DHCP address not changing ... generally it shouldn't.   When a DHCP lease reaches 50% of it's lifetime, it should try to automatically renew and thus never actually reach expiraition.   In my case, I've upgraded an SD STB to an HD STB  (the new box is on 104), so I'm thinking the old SD STB was on 101.    I was recently moving a cable around on the home entertainment center and in the process tripped the power strip -- so my DVR was rebooted and thus I suspect how it got a new IP address.

In the latter case, I think the reason the mapping didn't move was because of the UPnP stuff ... not entirely sure, but almost like the router thought the old rule was still valid, so it ignored the update request from the box when it moved.    Why the mobile device worked?  Now that one I can't figure out -- but once the rule moved -- everything worked.

So ... I'm not entirely sure "why" it occurs either.  But I think somehow getting the box to stay put once the rule is in place and using a static DHCP lease to do that, should hopefully at least prevent the circumstances where the box moves for some reason and the rule doesn't update.

My other thought was that maybe there's some "wakeup" sequence that gets sent to the boxes over the 8082 port -- and the web portal isn't sending it but the iPhone (or whatever server based pieces are behind it -- because I'm sure the iPhone isn't directly speaking to the box) causes the wakeup to be sent and gets the box to initiate the UPnP request to do the mapping.   I also noted that I have the "cleanup" rule turned off on the router -- to allow the router to purge old UPnP rules -- not sure if this is a cause -- or if down the road it might actually keep things working where otherwise they might break (because the cleanup might eventually purge the UDP rule).

Wish I knew more, but I'd almost have to put a sniffer on it see what was happening and unfortunately since all of that traffic goes over MoCA, there's no where I can't insert an ethernet probe.

It's definitely a bug somewhere however.  Hopefully the workaround I  suggested will keep it working for some folks.  I just now checked on my DVR and it's still up and accessible via the web portal.

Re: DVR web remote access
Enthusiast - Level 2


thanks for a very well explained fix for this problem.  I had used the Remote DVR without any problems, and about 3 weeks ago, I couldn't do anything.

Upon further inspection it looks like the IP Address was still the same, but the UDP port forwarding rule was missing from my router.  I added a new rule as per your settings, and "BAM!" it worked!  The only question is, why would the router suddenly drop a rule on its own.  I'm assuming the rule had been there previously since everything had worked before.

Thanks again for pointing me in the right direction to get this worked out. 

Re: DVR web remote access
Enthusiast - Level 3

The second rule get's added by the UPnP code I believe - and there is a setting which allows the router to clean up stale entries although a box  can also deregister the service if it stops functioning.   So I suspect maybe inactivity or something allowed it to be purged.

You could staticly defined the port forward as well to keep it from going away and turn off the UPnP code ... but be careful because if Verizon every changes the functionality inside the STB -- you'd have to catch that and update your box.

Either way .. now that everyone should know what to look for in their firewall rules, at least people can fix it if it becomes disassociated somehow.

- ravioli (aka "lasagna", I presently having an "out of userid" experience thanks to a Verizon account "upgrade")

Re: DVR web remote access
Enthusiast - Level 2

OK I've been getting the same message for several months including stb not responding.  Spent an hr on phone with tech support and after resetting and rebooting  everything still no luck.  I t did work a long time ago.  Then I remembered I had moved my dvr to a different coaxial cable to make it more convenient to program.  Just for the hell of it I went into menu>settings>dvr>remote enable/disable.  It showed enable  so I disabled it.  I then went back in and enabled it and it appears to be working again. For how long I don't know.  At the same time I added caller id but I don't think that was related to it apparently being fixed.