Elipsis 8 won't connect with my PC USB jack

I have had my Elipsis 8 for about 10 months and have never been able to get it to link up with my PC USB port.  I am using the same cable I use with my Samsung S5.

The prompt for using the USB link never comes on.

I have tried going into Airplane mode and that does not help.

Do I need to install a special driver on my PC?   The phone does not need it.

I have not been able to find a driver for the PC for this purpose.

1 Reply
Customer Service Rep

We hope you are enjoying the device, WEN1943. That is a great tablet and we understand of having it work properly with a PC. Let’s take a deeper look at the tablet and I’m sure we can get this solved together. What type of operating system does your PC currently have? Is that the same cable you charge the device with? Is that the same cable that came with the Samsung S5? Please provide a few more details and I’m confident we can get this resolved for you.
Follow us on Twitter @VZWSupport
If my response answered your question please click the 'Correct Answer' button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!