Totally puzzled

I Have 3 Ellipses 7 which is two more then I should have or should I say 3.  One of the goals to this tablet is be able to store and watch movies when traveling.  I discovered that the memory is a lot less then they make it out tto be.  Everytime I try to store a movie off of Vudu it tells be insuffient memory.  So I moved on with my life after reading tons of negative views about adding a memory card in the mix.  We'll eventually my Samsung Galaxy 5 had memory issues so I purchased 2 San Disks memory cards at 32G.  Only one of our Samsung phones had a memory card.  So I decided to take the 8G that was in the phone and put it into my sons Ellipse 7.  It worked like a champ.  I then went to staples tonight and purchased a 16 G Sandisk.  Tried it on my daughters Ellipse 7 and totally failed.  Tablet recognized but refused to record or read anything on this memory card.  I have no issues on using this card on other tablets.  I store tons of movies on it but when putting back in Ellipse it will not read it.  Went to Verizon store tonight and they had no solutions except to try to sell me the next Ellipsis.  I thought maybe the brand of memory cards would be the issue but he tried several of his personal cards with the same issue.   Is there a solution to this madness?