Verizon Cloud SMS Permission

I was just forced to upgrade to Premium Cloud service after Verizon took away my Free 5gb tier and threatened to delete my data. But now that I'm trying to expand what Cloud backs up to include my Messages, the app refuses.

Every time I try to enable Messages, I get a pop-up saying "Permission Needed" and telling me to go into my phone's settings to enable SMS Permissions for the Cloud app. However, all permissions including "SMS" are enabled already! I've tried disabling and reenabling it, closing the apps, and restarting my phone, but nothing works - I just keep getting the same pop up and Messages just won't enable. I have the most recent version of the app downloaded, and my phone's OS is up to date as well.

I guess now that I have to pay for this, I'd like it to actually work as intended. Is there anything that can be done to enable the backing up of Messages on my phone? I use the Verizon Message+ app for texting, by the way.

Thanks in advance

Labels (1)
Re: Verizon Cloud SMS Permission
Verizon Employee

Hello Chompy,

I am newer here to the board and saw your post.  The Verizon Cloud asks the device for permission to access, so either Messages+ or the OS has a block up.
since this is so much later, are you seeing this issue still and if so Tap the 'Send Feedback" feature in the Cloud (new) and let support know right away.
Cloud has also incorporated in the Android Release a way to gather logs and send to support for advanced troubleshooting.