Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
Showing results for 
Search instead for 
Did you mean: 
Ellipsis Jetpack will not connect to the internet

My laptop sees the Jetpack and lets me make a connection, but then it says there is limited access.  When I try to go to any website it says "internet explorer cannot display". When I click on Diagnose it tells me there isn't a modem or router.....  I'm 2 weeks into a data-plan that I cannot use at all and I've already received a new SIM card which didn't solve the problem.

I've used other wireless and mobile hotspot devices previously with no issue.  I tried using my brother's jetpack and received the same error messages.  Is there a setting on my laptop that needs to change?  I've adjusted the firewall and spyware thinking maybe those are inhibiting connection.  Does anyone have a thought?  Is there any other answer besides returning and cancelling the plan?

Labels (1)
Re: Ellipsis Jetpack will not connect to the internet
Customer Support

That is really strange, theonlydb! We're here to help offer suggestions on getting your jetpack connected. Let's first help verify if it is the jetpack or the computer that is causing the issue. Right now it appears to be your laptop as it cannot connect to a different jetpack. Have you tried connecting a different wireless device with your jetpack like a tablet, or handheld device? Are you able to connect to it?


Follow us on twitter @VZWSupport