Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
Showing results for 
Search instead for 
Did you mean: 
Cannot text to or receive texts on iPhone 4S

I have three phones on my Verizon family plan, including an iPhone added a couple of weeks ago. I just noticed today that the iPhone hasn't been receiving any text messages. I tried sending a text from the iPhone, but the message failed. I tried sending a text to the iPhone from another family-plan phone, and that text failed too (though other texts to/from that phone work fine). 


Any suggestions? I've already tried *228 option 2, but no change. I also checked for iOS updates in iTunes, but the phone's software is up-to-date.

Labels (1)
Re: Cannot text to or receive texts on iPhone 4S
Verizon Employee

Hello patrickandsarah,


I would like to make sure your text messaging is working as it should. Has the text messaging on the device started working at this time? Were your voice calls and data services working as normal? If necessary, please PM your name and cell number so that we can review the network settings further. Please let me know if I can provide additional assistance. 

Re: Cannot text to or receive texts on iPhone 4S

You are not alone.  I've just randomly started getting this same problem

I have an iPhone 4s running iOS 5.1.1.  It has worked perfectly since October 2011 until about 2 weeks ago when I suddenly stopped being able to both SEND and RECEIVE text messages.  When I send a Text Message, I get a "Message Send Failure."  People attempting to send me text messages receive no warning that it did not go through.

iMessages are not affected.  I can send iMessages to other iOS users.

What I have tried to do to fix the problem, but with no luck

1) Disabled iMessages completely in an attempt to avoid the "is the other person an iOS user?" check

2) *228 option 1 (reprogram your phone)

3) *228 option 2 (update your roaming information

4) Cleared all Network Setttings (General/Reset/Reset All Network Settings)

5) Restored phone to from a backup

6) Restored phone to factory default

No luck whatsoever.

This issue roughly corresponds with the activation of my wife's iPhone 4 a few weeks ago.  I would hardly say it is the cause, but the timing is suspicious given the changes to my wireless plan and the activation of a new device.