voice period not working in Messages+
mel8fox
Enthusiast - Level 1

For the past week or so when I voice-type "period" in Messages+, it types the word "period" instead of inserting the punctuation.  Saying "Question mark" and "comma" still insert the punctuation correctly.  The "period" works fine when talking into Google search, so the problem appears to be the Messages app, not the microphone.  I have a Samsung S10.  Help?!

0 Likes
Reply
1 Solution
Flyfisher666
Enthusiast - Level 1

Good news, for me, at least.  I signed on to the Samsung Community, posted the problem, and received the following suggestion, which totally fixed my problem:

 

 

 

VerbumVeritum
Epic Samsung Care Ambassador
 
 
Install GBoard from the Google Play Store and see if this issue persists. If it doesn't, Samsung Keyboard is the culprit.

View solution in original post

20 Replies
NebraskaGirl
Newbie

Hi did you get any help from Verizon? My phone does the same period vs . It is annoying me. I don't want them to say anything crazy like delete all your messages or something so I have been dealing with it. Thanks!!

0 Likes
Reply
mel8fox
Enthusiast - Level 1

I worked with tech support and  the issue was the Samsung keyboard.  They guided me to download Google keyboard (GBoard) and that has solved the problem.

0 Likes
Reply
vzw_customer_support
Customer Service Rep

mel8fox, that is excellent news! We're glad your situation has been resolved. We hope you have a great day! 

~Ivone

0 Likes
Reply
vzw_customer_support
Customer Service Rep

We want to make sure you are able to use your service without any issues, and we are here to help. We contacted you on Private Note to further assist you. ~Geo

0 Likes
Reply
mel8fox
Enthusiast - Level 1

What is "private note"?  I have not gotten a reply in any way that I know of

0 Likes
Reply
mel8fox
Enthusiast - Level 1

I uninstalled and reinstalled the Messages+ app, so I assume it's the latest version.  Changing my voicemail password would not help - this is an issue with text messaging, not phone calls or voicemails.  Other suggestions?

0 Likes
Reply
vzw_customer_support
Customer Service Rep

We're sorry the previous steps did not work mel8fox. When was the last time you were able to use Message+ without any issues? What device do you currently have? 

~Ivone

0 Likes
Reply
mel8fox
Enthusiast - Level 1

It's a Samsung S10 and this has been a problem for the past few weeks.  All other punctuation is dictated correctly except when I say "period" the app types the word "period" instead of inserting the punctuation. 

0 Likes
Reply
vzw_customer_support
Customer Service Rep

Wonderful! Thank you for keeping us posted, mel8fox. We're happy to hear that you were able to submit that feedback. This will definitely be the best way to ensure that our Message+ team is notified of this issue. We're a few clicks away if you need us. 

~Izzy

0 Likes
Reply
vzw_customer_support
Customer Service Rep

Thank you for checking, mel8fox! What options do you see on your device if you choose the Gmail option?

 

~Izzy

0 Likes
Reply
mel8fox
Enthusiast - Level 1

aha, now I see. I starts an email with verizon already included as recipient. I just sent it, so we'll see what happens....

0 Likes
Reply
vzw_customer_support
Customer Service Rep

I appreciate the additional details, mel8fox. This is certainly an odd error, and probably outside the scope of our normal troubleshooting steps. Not to worry though, as we want to get you directly in contact with the Messages+ team. To do this, please follow these steps to report a bug with the app: Open Message+ app > Click Menu > Get Help > Report Bug.

This is the quickest way to get something like this fixed, as it gets the necessary info right to the Message+ team. How does that sound?

-Joseph

0 Likes
Reply
CTalmage
Newbie

I'm having the same issue.  Thanks.

0 Likes
Reply
matulkru
Enthusiast - Level 1

So I reported this problem in Messages + as a bug.  Verizon came back asking if the behavior was the same in Samsung's Messages app.  It is!  So it's not just a Verizon Messages + problem.   (btw,  voice to text using Google and Bixby type the spoken word 'period' as punctuation)

Verizon responded, "

"This is because speech-to-text is a keyboard specific feature. You can try with installing Google keyboard from Playstore".   
 
After more research online, I did not take their suggestion  but instead I disabled "Samsung Voice Input" under Settings>General Management>Keyboard list and default>
So now, in Verizon's Message+, in a text, when I select the microphone to voice type from the Samsung Keyboard, by default, it gives me the Google Voice Typing dialog.  Samsung Voice Input is no longer an option when tapping the keyboard icon in the bottom right hand corner of the text.
 
Another option would be to not disable "Samsung Voice Input" but when choosing to voice text, select the keyboard icon in the bottom right hand corner of the text and select "Google Voice Typing".   You would have to do that each time you wanted to voice to text and  involves extra tapping which I elected not to do.
 
0 Likes
Reply
Flyfisher666
Enthusiast - Level 1

I started experiencing the same problem with periods spelled out in voice texting with Messenger+ using my Samsung Galaxy Note 10.  I reported the bug to the Verizon Messenger" team that you referred to.  I got a very quick but fairly useless reply stating: "Hi, This is a Samsung Keyboard issue.  Thanks.

I took this to mean that Verizon is washing its hands of the issue  and is subliminally telling me to speak to Samsung.  I haven't had the time to follow up with Samsung on that, but thought I would pass this on to you.

0 Likes
Reply
mel8fox
Enthusiast - Level 1

Thank you. I worked with tech support and yes, the issue was the Samsung keyboard.  They guided me to download Google keyboard and that has solved the problem.

0 Likes
Reply
Flyfisher666
Enthusiast - Level 1

Good news, for me, at least.  I signed on to the Samsung Community, posted the problem, and received the following suggestion, which totally fixed my problem:

 

 

 

VerbumVeritum
Epic Samsung Care Ambassador
 
 
Install GBoard from the Google Play Store and see if this issue persists. If it doesn't, Samsung Keyboard is the culprit.
mel8fox
Enthusiast - Level 1

Thank you, this is what tech support guided me to do, and now I can make it work

0 Likes
Reply
mel8fox
Enthusiast - Level 1

Thank you for the help Joseph.  When I click "Report a Bug"  I get a screen that gives me options of who/how to share a zip file with (options are quick share, message+, gmail, chrome).  Who do I send it to? Thanks

0 Likes
Reply
vzw_customer_support
Customer Service Rep

In this case, we would recommend using Gmail or your normal email app, the address will appear when you pick the option.

~Freddy

0 Likes
Reply