Turned off spam filter still collecting emails

Because the spam filter is too aggressive -- collecting 9 legitimate messages for every actual spam -- I turned it off. When mail continued to go missing, I checked it and discovered that mail is still being filtered in the spam folder. My settings show that it is turned off. I attempted to toggle it back on again to see if switching it back and forth would actually turn it off, but received an error and was unable to turn it on. Mail continues to collect in the folder. Help?