cannot connect safely to server
Billy821
Enthusiast - Level 2

My Samsung Galaxy Avant is not loading new emails; "cannot connect safely to server" is shown after any attempts to change settings. Emails are coming in at AOL and MacMail on home computer but not on the phone.  Outgoing mail is working however.  Using the Android email that comes with the phone. Never had a problem until this week.

Any suggestions?

0 Likes
Reply
47 Replies
NoNameCC
Enthusiast - Level 1

I submitted the following to AOL support via email on 2/27, and received the reply below a week later.  The reply doesn't say that the problem has been resolved, simply that they are aware and working on it.

"My GMail client on my phone stopped syncing my AOL/Verizon.net emails about a week ago. I have tried deleting the account and re-creating it, but when I choose the settings in your online help article, I get an error message saying "Can't safely connect to server. (Certificate hostname not useable for server: pop.verizon.net)
I have tried all four encryption options offered. Nothing works. 
I am using Android 6."

Their reply:

"We apologize for the inconvenience, however, there was an issue with our email service that may have caused the problems you are describing. At this time, that factor has been identified and is currently being addressed. While we cannot provide a specific time when the issue will be resolved, please be assured that our team is working to correct it as soon as possible.
Again, our apologies and thank you for your patience."

 

0 Likes
Reply
pjchris
Enthusiast - Level 2

I finally got e-mail working again on my Samsung Nook (SM-T230NU).  It had been working fine, then started reporting the "cannot safely connect to server".  After searching everywhere for tips, here is the combination of things that got it going:

1.  Put in your name and e-mail account PW

2. Select Manual Setup

3. Select POP3 account type

4. Change your name from XXXXX   to XXXXX@verizon.net

5. Change the SSL to "SSL-accept all certificates"

That did it for me.  Hope it helps someone else.

Paul

0 Likes
Reply
Varg
Enthusiast - Level 3

Thanks, Paul. "SSL - accept all certificates" is the only solution that worked on my old Galaxy TabPro.

0 Likes
Reply
gtwassociates2

Another issue ... My Samsung phone can connect to my email at verizon.net ... I use the settings at verizon.net etc ... But the tablet Samsung Galaxy stops at the set up process with a message "cannot connect to to the server" the set up process in the tablet does not seem to allow setting ports ... message appears at step of setting up the incoming server I believe ...anyone know an approach to adding my email at verizon.net to my Galaxy tablet?

0 Likes
Reply
tns2
Community Leader
Community Leader

Which email program Samsung EMail, gmail, Other.

I've seen that message with gmail, and for that you just have to change the settings to allow it to connect despite the warning. 

For others you do have to go into settings and make sure it is using ssl.  Usually once you set that it correctly sets the port ids.  Password is normal (i.e clear text).

dexman
Community Leader
Community Leader

I've tried all of the suggested changes posted earlier in the topic, but, I still can't get past the "Cannot safely connect to server" on my retired Samsung Galaxy S4 when trying to add my @verizon.net Email account.

No issues adding the account to my Samsung Galaxy S7 Edge and my Windows 10 devices.

Has this become a lost cause? ☹

0 Likes
Reply