error 0x800ccc0f receiving verizon.net email 2012 via COMCAST using MS Outlook Express. I fixed it.
chadbox
Enthusiast - Level 1

Running MS Outlook Express 6 under MS XP via Comcast internet
connection using latest documented Verizon email parameters of POP3,
incoming.verizon.net port 995, SSL, (POP3)
outgoing.verizon.net port 465, SSL, (SMTP)
gets the following MS error:

 Your server has unexpectedly terminated the connection. Possible causes for this
 include server problems, network problems, or a long period of inactivity. Account:
 'incoming.verizon.net', Server: 'incoming.verizon.net', Protocol: POP3, Port: 995,
 Secure(SSL): Yes, Error Number: 0x800CCC0F

I am a subaccount of a Verizon FIOS connection. 
I am going to move soon to that location.
I have terminated all of my other $ cost email accounts.

I changed to these email parameters early December 2011 per
a Verizon Dec 14, 2011 email.
It worked, I think. I went on vacation. I returned.
On first use January 7, it failed with the above error.
MyVerizon WEB mail works OK to this account.
I never install software from Verizon nor Comcast.
It is pure MS email with parameters typed in by me.
I use MS XP Firewall and System Mechanic ilo System Shield
anti-virus with email checking.  Turning these off made no difference.

After days of web search and many trial and errors, I found
instructions on how to trace Outlook Express internal email commands.

1) Start Outlook Express in the normal manner
   (its internal name is Msimn.exe)
2) Click Tools
3) Click Options (this is related to the (Switch) Identity
   that you are currently using)
4) Click Maintenance
5) Under Troubleshooting, click Mail, click OK.
ALL Tools - all Accounts and Options changes appear to take effect
immediately after OK or Apply, so you do not need to stop and restart
Outlook Express.

Click Send/Recv to retry the receive and so trace the error.

All internal commands and responses are now traced in (XP)
C:\Documents and Settings\youruserid\Local Settings\Application Data\
Identities\{91C1BAF3-170C-4678-9B37-1DAB3541704A}\Microsoft\
Outlook Express\Pop3.log

It is probably easiest to just Search C: for Pop3.log
and then click File, click Open With, click Notepad.
(I set all .log to use Notepad)

The trace keeps adding to the end of this file.

You can use Notepad.exe to examine this file while it is still OPEN,
but you may have to reOPEN it to refresh and thus see the added trace lines.

The trace that I got in Pop3.log is

Outlook Express 6.00.2900.5931 (xpsp_sp3_gdr.100129-1321)
POP3 Log started at 01/11/2012 18:39:02

That is not much!

HEY, THIS IS THE FIX:

I decided to reset the email parameters to their previous values: POP3,
incoming.verizon.net port 110, no SSL, (POP3)
outgoing.verizon.net port  25, no SSL, (SMTP)

1) Start Outlook Express in the normal manner
   (its internal name is Msimn.exe)
2) Click Tools
3) Click Accounts
4) Click Mail, click incoming.verizon.net, click Properties
5) Clear both boxes This server requires a sequre connection (SSL)
   Click Use Defaults (this should set Outgoing port to 25)
   Make sure Outgoing mail (SMTP) has port  25.
   Make sure Incoming mail (POP3) has port 110.
   Make sure both SSL boxes are still blank.
6) Click OK.

Then did Send/Recv.

Unbelievable! It worked! In spite of everything Verizon said
in their email and online email setting write ups.


The trace that I got in Pop3.log is

Outlook Express 6.00.2900.5931 (xpsp_sp3_gdr.100129-1321)
POP3 Log started at 01/11/2012 18:52:24
POP3: 18:52:25 [rx] +OK Messaging Multiplexor (Sun Java(tm) System Messaging Server 6.3-11.01 (built Feb 12 2010)) <4a84654f944c8f82eac009d8e2853318@vms171039.mailsrvcs.net>
POP3: 18:52:25 [tx] USER xxxxxxxxx@verizon.net
POP3: 18:52:25 [rx] +OK password required for user xxxxxxxxx@verizon.net
POP3: 18:52:25 [tx] PASS *******
POP3: 18:52:26 [rx] +OK Maildrop ready
POP3: 18:52:26 [tx] STAT
POP3: 18:52:26 [rx] +OK 5 659684
POP3: 18:52:26 [tx] LIST
POP3: 18:52:27 [rx] +OK scan listing follows
POP3: 18:52:27 [rx] 1 15260
POP3: 18:52:27 [rx] 2 4425
POP3: 18:52:27 [rx] 3 6125
POP3: 18:52:27 [rx] 4 625937
POP3: 18:52:27 [rx] 5 7937
POP3: 18:52:27 [rx] .
POP3: 18:52:27 [tx] RETR 1
POP3: 18:52:27 [rx] +OK 15260 octets
POP3: 18:52:27 [tx] RETR 2
POP3: 18:52:27 [rx] +OK 4425 octets
POP3: 18:52:27 [tx] RETR 3
POP3: 18:52:28 [rx] +OK 6125 octets
POP3: 18:52:28 [tx] RETR 4
POP3: 18:52:28 [rx] +OK 625937 octets
POP3: 18:52:29 [tx] RETR 5
POP3: 18:52:29 [rx] +OK 7937 octets
POP3: 18:52:29 [tx] DELE 1
POP3: 18:52:29 [rx] +OK message deleted
POP3: 18:52:29 [tx] DELE 2
POP3: 18:52:30 [rx] +OK message deleted
POP3: 18:52:30 [tx] DELE 3
POP3: 18:52:30 [rx] +OK message deleted
POP3: 18:52:30 [tx] DELE 4
POP3: 18:52:30 [rx] +OK message deleted
POP3: 18:52:30 [tx] DELE 5
POP3: 18:52:30 [rx] +OK message deleted
POP3: 18:52:30 [tx] QUIT
POP3: 18:52:31 [rx] +OK

Post Script: more experimenting shows that
@verizon.net is not needed in the above USER trace command.
It comes from Tools - Accounts - Mail - incoming.verizon.net -
Properties - Servers - Incoming Mail Server - Account name .
Just User name xxxxxxxx is enough. (Your name, not xxxxxxxx.)

Also, AUTH is not accepted. This comes from ... Servers -
Log on using Secure Password Authentification.

It would be nice if AUTH, and the ports 995, 465, SSL worked
to give us better security.

It is unclear which Use SSL x.x needs or should be checked for SSL.
See Internet Explorer - Tools - Internet Options (Internet Properties)
or Control Panel - Internet Options (Internet Properties)
-- Advanced - Use SSL x.x .


I guess that they negotiate to use the best SSL
that they have in common, but we should be told what is the best.

I guess that Comcast did something on January 1, 2012 to make this
not work. Then Verizon did something to make the previous parameters
work, at least for Comcast connections.
But Comcast and Verizon failed to document this.

This is my documentation for those people affected by this.