Cosmos touch help

I have a Cosmos Touch I have had it for a while now and having many problems with it. First, when I send a text it always sends doubles! This annoys not only myself, but my contacts as well. Second, when I text one of my friends my phone will automatically send it to his landline work number, I can't get it to stop. Anyone else having either of these issues??

Labels (1)
Re: Cosmos touch help
Super User
Super User

To prevent sending texts to the landline number, make sure that the mobile number is selected as the DEFAULT for that contact.  Right now, my guess is the HOME phone is the default, so when you pull up that contact by name, it will default to the home phone.

As far as sending duplicate texts, it happens and I 'm not sure why.  My daughter had a phone that would send 2 oe 3 of the same text every time; it stopped when she got anew phone.

Re: Cosmos touch help
Customer Service Rep

I can see why you're frustrated, bartongrad12! I have not heard about this problem on the Cosmos Touch. I would suggest completing a master reset. Please see the instructions below:

****This procedure will erase all user data and restore the handset to the original factory settings.

1. From the main screen, touch Menu.
2. Touch Settings.
3. Touch Phone Settings.
4. Touch Security.
    If prompted, touch OK.
5. Enter the Security Code (default is the last      4 digits of the phone number).
6.Touch Restore Phone.
7. Touch OK.
8. Enter the Security Code (default is the last 4 digits of the phone number).

Let me know if this resolves your messaging issues. Have a great day!


Follow us on twitter @VZWSupport