Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
iPad 3 constantly dropping strong 4G LTE signal
vzwuser571
Member

My iPad 3 suddenly refuses to hold the very strong (5 bars) 4G LTE signal here at work. The LTE signal is very strong here, my iPad has always had an excellent LTE signal since I activated it a few months ago. Now, it grabs the LTE signal immediately -- five bars -- and gives me LTE speeds. This lasts only for a couple of minutes. After a couple of minutes, it suddenly says **Could not activate data cellular network** and reverts to 3G. This never used to happen, but has been happening for the past several days now.

I've tried resetting network settings, airplane mode on/off, turn wireless off, turn on/off cellular data, hard reset of the iPad, full shutdown of the iPad. Nothing worked.

I've Googled, and this appears to be a fairly common issue without any clear resolution. What's the answer?

Labels (1)
Tags (1)
0 Likes
1 Solution

Correct Answers
Re: iPad 3 constantly dropping strong 4G LTE signal
vzwuser571
Member

MarquiaF_VZW - thanks for the reply. With more Googling and messages on other forums, I resolved this on my own. To cut to the chase and hopefully help others, here's the answer. I'll also more fully describe the issue below the answer:

ANSWER

(1) Go to Settings.

(2) Go to General.

(3) Choose Reset.

(4) Choose Subscriber Services.

(5) Select Reprovision Account.

(6) Reboot iPad.

This completely fixed the issue for me. My LTE has been solid since performing this fix two weeks ago. Before doing this, I tried pretty much everything else you can try short of getting a new SIM card.

PROBLEM

This was not a Verizon coverage issue. 4G is very strong here at work, and it is reasonably strong at home. I never had any 4G issues at either place, then suddenly I had them constantly. My iPad would latch onto the (5 bar) 4G signal quickly, give me 4G service for 30 seconds to a couple of minutes, then drop it for 3G, sometimes also displaying a "Could not activate data cellular network" message. It would stay at 3G unless I reset the iPad, shut it down completely, reverted to all defaults, or whatever. Then I'd get 4G right away again, but dropping to 3G the same way within a minute or two again.

I saw this exact same issue at the following thread, where I also posted, and where someone suggested the "reprovision account" solution: http://forums.macrumors.com/showthread.php?t=1535823

That solution worked perfectly for me and a few others on that thread, but not everyone. I suspect that for the others, they may have actual 4G coverage or antenna or SIM card issues. For me, it was apparently an issue where VZW didn't recognize my iPad / account any more, for whatever reason. Reprovisioning was the way to go. I'll try to mark this thread as "answered" to help other people, or perhaps you at VZW can mark it.

Thanks for contacting me. VZW support and the 4G LTE service are excellent.

View solution in original post

Re: iPad 3 constantly dropping strong 4G LTE signal
vzw_customer_support
Customer Support

We can't certainly find a resolution together vzwuser571. Are you able to access 4G at home or other locations since this issue started? Do you or your co-workers have other 4G devices? Are those having problems as well? If this is affecting multiple devices, or only happening at work & not other 4G locations, we may need to submit a resolution ticket for our network team to further investigate.

MarquiaF_VZW
Follow us on Twitter @VZWSupport

0 Likes
Re: iPad 3 constantly dropping strong 4G LTE signal
vzwuser571
Member

MarquiaF_VZW - thanks for the reply. With more Googling and messages on other forums, I resolved this on my own. To cut to the chase and hopefully help others, here's the answer. I'll also more fully describe the issue below the answer:

ANSWER

(1) Go to Settings.

(2) Go to General.

(3) Choose Reset.

(4) Choose Subscriber Services.

(5) Select Reprovision Account.

(6) Reboot iPad.

This completely fixed the issue for me. My LTE has been solid since performing this fix two weeks ago. Before doing this, I tried pretty much everything else you can try short of getting a new SIM card.

PROBLEM

This was not a Verizon coverage issue. 4G is very strong here at work, and it is reasonably strong at home. I never had any 4G issues at either place, then suddenly I had them constantly. My iPad would latch onto the (5 bar) 4G signal quickly, give me 4G service for 30 seconds to a couple of minutes, then drop it for 3G, sometimes also displaying a "Could not activate data cellular network" message. It would stay at 3G unless I reset the iPad, shut it down completely, reverted to all defaults, or whatever. Then I'd get 4G right away again, but dropping to 3G the same way within a minute or two again.

I saw this exact same issue at the following thread, where I also posted, and where someone suggested the "reprovision account" solution: http://forums.macrumors.com/showthread.php?t=1535823

That solution worked perfectly for me and a few others on that thread, but not everyone. I suspect that for the others, they may have actual 4G coverage or antenna or SIM card issues. For me, it was apparently an issue where VZW didn't recognize my iPad / account any more, for whatever reason. Reprovisioning was the way to go. I'll try to mark this thread as "answered" to help other people, or perhaps you at VZW can mark it.

Thanks for contacting me. VZW support and the 4G LTE service are excellent.

Re: iPad 3 constantly dropping strong 4G LTE signal
iAndy
Member

You are my savior. The trick perfectly worked to fix the same issues on my iPad Mini 4. Thank you very much!!!

0 Likes