Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
When I send a text to another phone, it shows up on the other phone as coming from email address and not from phone number.
cfm007
Member

I just came over from Sprint 4 days ago and had my number ported over. When I send a text to another number, it shows up on the other phone as coming from email address and not my phone number. For example, if the recipient of the text has me in the contacts as "Tom", the text comes to them displaying my email address instead of "Tom".

Labels (1)
0 Likes
1 Solution

Correct Answers
Re: When I send a text to another phone, it shows up on the other phone as coming from email address and not from phone number.
vzw_customer_support
Customer Support

cfm007,

Welcome to our family. We want you to be able to enjoy all the services we provide and we definitely need to address this. Do you receive/make calls without problems? Are you able to receive messages with your contacts' number? Are you using iMessages? If so, go to Settings>Messages>Send&Receive>only your phone number should be enabled.

AdaS_VZW
Follow us on Twitter at @VZWSupport 

View solution in original post

0 Likes
Re: When I send a text to another phone, it shows up on the other phone as coming from email address and not from phone number.
vzw_customer_support
Customer Support

cfm007,

Welcome to our family. We want you to be able to enjoy all the services we provide and we definitely need to address this. Do you receive/make calls without problems? Are you able to receive messages with your contacts' number? Are you using iMessages? If so, go to Settings>Messages>Send&Receive>only your phone number should be enabled.

AdaS_VZW
Follow us on Twitter at @VZWSupport 

View solution in original post

0 Likes
Re: When I send a text to another phone, it shows up on the other phone as coming from email address and not from phone number.
cfm007
Member

On a tip from a friend who once had a problem like this, I went to Settings>General>Reset>Rest All Settings and now only my phone number is enabled in iMessages; so, it's fixed. Apparently, when I originally restored the new phone from iCloud, the iMessage settings got messed.

Thanks.

0 Likes