Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
iPhone 6+ will not update newer than iOS 12.5.1
JJSM
Member

My iPhone 6+ is running iOS 12.5.1 and indicates “Your software is up to date.”  How do I get it to update to the latest version: iOS 14.4?

0 Likes
2 Solutions

Correct Answers
Re: iPhone 6+ will not update newer than iOS 12.5.1
JJSM
Member

Apple tells me that iOS 12.5.1 is the most current OS that the 6Plus will run. If it were the 6s Plus, it would run OS 14.4.

View solution in original post

0 Likes
Re: iPhone 6+ will not update newer than iOS 12.5.1
vzw_customer_support
Customer Support

At this time Apple has only released iOS 14.4 for the iPhone 6S, and 6S plus models. If your model iPhone is the iPhone 6, you may not receive the update until Apple releases a version for this model device. 

View solution in original post

0 Likes
Re: iPhone 6+ will not update newer than iOS 12.5.1
JJSM
Member

Apple tells me that iOS 12.5.1 is the most current OS that the 6Plus will run. If it were the 6s Plus, it would run OS 14.4.

0 Likes
Re: iPhone 6+ will not update newer than iOS 12.5.1
acraftylady2
Sr. Member

I would contact ao

I would contact apple again and ask how the heck are you supposed to fix the security flaw if you can't  update to 14.4 like they are urging everyone to do.  What a mess.

 

0 Likes
Re: iPhone 6+ will not update newer than iOS 12.5.1
Tigerstep
Sr. Member

You've reached end of life support by the sounds of it, you got way more updates than an Android phone would have.

Unless you can't use any specific apps anymore, I see no reason to change phones yet.

0 Likes
Re: iPhone 6+ will not update newer than iOS 12.5.1
acraftylady2
Sr. Member

But what about apples latest security flaw needing to immediately update to 14.4?  Never owned apple but if they can't update to 14.4 then won't their phone be unsecure and vulnerable or does the security flaw not apply to older devices?  Ok I see the security issue is 6s  and later so guessing the 6+ is older than that?   Mary

0 Likes
Re: iPhone 6+ will not update newer than iOS 12.5.1
vzw_customer_support
Customer Support

At this time Apple has only released iOS 14.4 for the iPhone 6S, and 6S plus models. If your model iPhone is the iPhone 6, you may not receive the update until Apple releases a version for this model device. 

0 Likes