MiFi 4510L not broadcasting an SSID

So I purchased a 4510 to replace my 2200.  I got it all activated last night and it worked flawlessly on my Mac, ipad, iphone, etc.  I bring it in to work today.  Turn it on and can't find the SSID with either my two laptops(one windows, one mac), my iphone, or my ipad.  


I decided to turn it off , turn it back on. Again no SSID.  I DID NOT change it to NOT broadcast.  I tried manually entering the SSID and password into my mac.  Could not find that network.


I then decided to reset the sim card.  No change.  


I also did 3 hard resets and still SSID or network for me to access?  What am I missing here?  Am I making a mistake or is something up with the unit?


The antenna has full bars.  The light is bright green.  The battery is fully charged.


Any help is greatly appreciated.

Re: MiFi 4510L not broadcasting an SSID

I'm having the exact issue you describe, with multiple 4510Ls.  I use one personally, and have also been setting up two other 4510s for my customers over the past couple of days.  In my office, I see several other WiFi networks, but the MiFi 4510s do not show up.  Actually, if I reset the 4510 several times, it MIGHT show up as a WiFi network for a brief period of time. 


I took two of the 4510s downstairs, to a less WiFi congested part of the building, and started one up. I immediately saw the Verizon SSID show up on my iPad, iPhone, and Blackberry.  I ensured that all three devices could join the network and surf the 'net.  Then, I shut down that MiFi and started up the other one.  Same result: in this location, where there aren't too many WiFi networks showing up, the MiFis work fine.


However, I took them back upstairs, and once again ran into the issue where none of my devices would see the Verizon SSIDs.  My client devices are all within 5-10 feet of the MiFi, as they were when I was downstairs and this all worked.


I'm assuming that one of these may be true:


1) The MiFi's signal is so very weak, that it can't compete with the stronger networks in use in and around my office.  (Less Likely)


2) When the MiFi boots up, it searches for an empty WiFi channel to broadcast.  When it can't find one that it likes, it simply does not broadcast an SSID, rendering the MiFi completely inaccessible. (More likely)


Whatever is going on, I sure hope that Verizon can fix it.  Soon.  This is a huge problem for what is otherwise a good device.  I've gotten 4 customers to upgrade from their MiFi 2200, and am really afraid that recommendation is going to come back to bite me.


I should also mention that I've seen these exact symptoms with the Verizon Samsung 4G Hotspot LC-11 (I might be slightly off on that model number.)


Re: MiFi 4510L not broadcasting an SSID
Champion - Level 1

One thing you could try would be assigning a channel to the MiFi instead of letting it choose one for itself.


To change the Wireless Channel:

1. Boot up the MiFi

2. Connect to the MiFi wirelessly

3. Navigate to http://mifi.admin

4. Sign into the MiFi with your Router Password

  a. By default the password is "admin"

5. Click the Wi-Fi tab

6. Change the Channel to 4

  a. If you happen to know 4 is taken then try 7 or 10

7. Click Apply

8. Tes the connection in the congested area


While you are in Wi-Fi tab you might also want to try switching the 802.11 mode from B/G/N to just B/G.  Many users have reported better results when eliminating the Wireless N broadcast mode.  Also remember that the range of the MiFi is severely more limited than most other wireless networks.  Try to keep the MiFi near you when you do your testing.

Re: MiFi 4510L not broadcasting an SSID
Enthusiast - Level 2

I had a similar problem (See my post) and figured out a way around it.


1. Use a wifi tool like "http://tools.meraki.com/stumbler#q=" to find wifi networks in the area you are having a problem. I used a very very slow public network.

2. See which channels and 802.11 protocols are least used.  In my case only channels 1,6 and 11 were being used and all were 802.11 B or G.

3. make a note of above.

4. connect mifi to verizon in non congested area, and ssid should be broadcast. 

5. point browser to 

6. change wifi settings to something that will work in your congested area. I chose the 802.11n protocol and wifi channel 4.

7. try mifi in congested area.



Worked like a charm!! I think the mifi has trouble with selecting a wifi channel in a congested area. hopefully this can be addressed in a firmware upgrade, but in the meantime, this works.


Kudos appreciated :smileywink:

Re: MiFi 4510L not broadcasting an SSID

I can confirm this same behavior on the Samsung SCH-LC11 device. The device worked great at Chicago's Midway airport and on the train into the city. Once in downtown, the device no longer transmitted its SSID and the WiFi LED never came on. :smileysad: No amount of power-cycling or resetting would fix the problem. Once I got back home (suburban area outside Denver) the device operated normally.

Re: MiFi 4510L not broadcasting an SSID

I have had the same problem over and over again. I found a temp fix though that seems to work until I shut down the laptop. I have the issue with WIndows XP and Windows 7.  I reset TCP/IP and for whatever reason I am able to see the Mifi. This is for PC only I am not sure how to do this on Mac, or if it's even possible.


To reset TCP/IP open a command prompt and type the following command:

netsh int ip reset


You may have to restart your computer but I have been okay without restarting. If you guys have any more info that would be great.

 ps: I have also noticed that while my laptop cannot see the mifi at times, my cell phone picks up the signal. strange.