2 HRS <s>25</s> 33 Minutes and still counting
Enthusiast - Level 2

You have to hand it to Verizon for not seeming to care about their customers.

I just upgraded my firmware (big mistake apparently) and now my laptop cannot connect wirelessly to the internet.

After waiting over 40 minutes on hold for a technician, I was greeted by a rude and uncaring support person named Sara.

She wasn't able to resolve the problem, so she forwarded me somewhere else.  Another 5 minutes later, I was connected to a higher level support.  That rep wasn't able to help me and was going to forward me yet again, and said it would only be 1 or 2 minutes.  Well, that  was about an hour and a half ago.  After 2 1/2 hrs of listening to this music and getting nowhere, I am about ready to blow my top.

In the meantime I havve checked and double and triple checked my settings (which had not changed by me at lest) and everything seems to be what they should.

Has anyone experienced this problem and know of a fix?  I was going to restore the old firmware but it appears that option is no longer available with the Actiontech router anymore.  I'm using, previously 20.10.7.  The router is the actiontech mi424wr-gen2 rev f

If anyone can help I'd be much obliged

Re: 2 HRS <s>25</s> 33 Minutes and still counting
Champion - Level 3

When you say it cannot connect, what exactly do you mean? Is your laptop seeing your network? Is is connecting to the networks, but just not the internet? Have you deleted the network profile completely and connected anew?

Re: 2 HRS <s>25</s> 33 Minutes and still counting
Enthusiast - Level 2

For reasons I do not understand, somehow my key letters changed from lower case to upper case and as a result the authentication was failing.  Windows all this time was reporting a security settings mismatch, which is true, but the security settings apart from the key info was correct. 

Long story short, the problem is solved though I have no idea how I could not connect right after the upgrade  - makes no sense at all.

Anyhow, thanks for the response.