Can't Activate new DSL service - please help
Enthusiast - Level 1

It has been impossible to active my new DSL service. I have tried 3 different modems and even using one modem in bridge mode connected to the laptop and created a PPPOE connection on the laptop and got the exact same result on all connections.

I can from the DOS prompt ping, etc. without any issues so the network connection has to be working. But as soon as I try to go to the verizon activation page I get nothing. Also trying to ping I got one ping every 20 or so all others time out.

I figure I would call support. Had to hold on line for about 1 hour before someone got on the phone. He didn't seem to understand my problem or issue. After I explained what I did to get activated, and that I could ping google and , he asked me if I was sure my ethernet cable was plugged in into my laptop........  and kept asking question that didn't make any sense.  Like did you connect a phone line to the modem. (this is afte I explained I can ping google and
Any after an hour on the phone with him I still couldn't get to the activation page. He then hung up on me and never called me back.

I tried the activation page from a friend house and it works. I even went through the setup and filled out all the questions, but not sure if it really activated it or on because I was not at my house. I won't be able to check until late tomorrow if this worked.

Anyone have any ideas what I need to do if the activation didn't go through?
{edited for privacy}

Re: Can't Activate new DSL service - please help
Super User
Super User

At this location (not a friend's house) can you get access to any web pages that are on the Internet?

For example