Skip to main content
Accessibility Resource Center Skip to main content
Get up to $500 when you bring the phone you love. OR get iPhone 13, on us. Online only. With Select 5G Unlimited plans. Ends 1.31. Buy now
end of navigation menu
Don't see my Xbox from my Microsoft Surface (Devices)
DmitriyS1
Enthusiast

Hi,

I just switched from RCN to FiOS Internet.

I was able to add my Xbox to the devices (Microsoft Surface), but currently my MS Surface don't see Xbox.

The XBox directly connected to the WiFi router and my surface is connected wirelessly.

Maybe I should enable something on my router, but I could not find what exactly. Smiley Sad

My PC (Windows 😎 connected by the cable and can see Xbox.

Any advise?

Dmitriy

Labels (1)
0 Likes
1 Solution

Correct answers
Re: Don't see my Xbox from my Microsoft Surface (Devices)
Hubrisnxs
Legend

well I have noticed a problem that might fall under this catagory. 

So try the following,  log into the router at http://192.168.1.1 and then go to the

  • advanced at the top menu.
  • accept the warning
  • go to igmp proxy
  • select disable
  • Save.
  • Test

View solution in original post

Re: Don't see my Xbox from my Microsoft Surface (Devices)
Hubrisnxs
Legend

do you have multiple routers, or are they connected to the same SSID and Password? 

0 Likes
Re: Don't see my Xbox from my Microsoft Surface (Devices)
DmitriyS1
Enthusiast

I have just one router.

My PC and Xbox connected directly by cable to it and my Surface wirelessly.

Maybe should try, instead of connecting by cable, to connect the XBox thru WiFi, to see if it will be discoverable, but I want to have a stable speed on my XBox, because I watch a lot of movies on it.

Wirelessly, in ideal situation (couple feet) I have about 30/25 speed, usually it's just 20/15

0 Likes
Re: Don't see my Xbox from my Microsoft Surface (Devices)
Hubrisnxs
Legend

well I have noticed a problem that might fall under this catagory. 

So try the following,  log into the router at http://192.168.1.1 and then go to the

  • advanced at the top menu.
  • accept the warning
  • go to igmp proxy
  • select disable
  • Save.
  • Test
Re: Don't see my Xbox from my Microsoft Surface (Devices)
DmitriyS1
Enthusiast

Oh, man thanks a lot! I spend a whole day of trying to figure out what is wrong. I improved the performance of my Internet and I worried that I touched some other settings, which blocked discovering my XBox.

I found more info what is IGMP proxy here - http://forums.verizon.com/t5/Home-Networking/Apple-AIRPLAY-issue-w-Acontech-Router-IGMP-Proxy-needs-...

0 Likes