Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
How to get 130mbit with MI424WR-GEN3I?
alleskacke
Enthusiast

So I fell for the ads promising awesome wireless speed with the new MI424WR-GEN3I router. Well, I can't get that working so fast.

Firmware:

Firmware Version:40.21.10.2
Model Name:MI424WR-GEN3I
Hardware Version:I

Current Settings:

Radio Enabled:Yes
SSID:*****
Channel:4
Security Enabled:Yes
        WEP 64-bit:N/A
        WEP 802.1x:N/A
        WPA2:*****
SSID Broadcast:Enabled
MAC Authentication:Disabled
Wireless Mode:Compatibility Mode(802.11b/g/n)
WMM:Disabled
WPS:Disabled

I can stand right next to the router with 3 different devices (one at a time) that support N... nobody gets more than 65mbit. Currently I use "150Mbps Wireless 802.11b/g/n Nano USB Adapter".

Things I tried:

- performance wireless mode (half of my wireless devices wont connect at all anymore)

- different channels

- WMM on/off

- WPS on/off

- WEP/no WEP / WPA / WPA2

- AES / TKIP on/off

The logs also contain nothing, or I dont know what to look out for.


So far it looks I went from 54mbit to 65mbit, not worth $100 😞

Ideas anyone?

Labels (1)
0 Likes
Re: How to get 130mbit with MI424WR-GEN3I?
gs0b
Super User
Super User

You may have too much interference in the 2.4GHz band.  Get a copy of inSSIDer for Windows.  It's a free program that will show you what other WiFi networks are operating in your area.  This will help you find the least used channel.  Then, change your router to operate on that channel.

If 2.4GHz looks too full, you may be better off getting your own dual-band access point / router.

Good Luck.

Re: How to get 130mbit with MI424WR-GEN3I?
alleskacke
Enthusiast

I tried that, that's why I picked channel 4... no other networks on that channel in the neighborhood.

0 Likes
Re: How to get 130mbit with MI424WR-GEN3I?
gs0b
Super User
Super User

802.11 takes up more than one channel.  The channel assignment is the center frequency.  inSSIDer shows the full width of the channels.  The only channels that do not overlap are 1, 6 and 11.  Channel 4 will overlap with 1 and 6.  It is best to stay on 1, 6 and 11.

By the way, I get 130Mbps all day long from my Gen3 Actiontec.  I live in a single family home in the suburbs, so my neighbors WiFi are all a good distance away.  There aren't any completely clear channels near me.  My network is a good 30dB higher than my closest neighbor.

I also have one Dell computer that refuses to connect at higher than 65Mbps even when next to a computer that gets 130Mbps al day long.  I've yet to figure out why; but since it also has Ethernet I haven't tried that hard.

Good Luck.

Re: How to get 130mbit with MI424WR-GEN3I?
walt178
Specialist

Change wireless mode to Performance mode (802.11n) rather than compatibility mode.  Compatibility mode will not allow you to achieve the full  N speeds.   The trade off is that if you have any G devices they won't work in Performance mode. 

Re: How to get 130mbit with MI424WR-GEN3I?
alleskacke
Enthusiast

Thanks for the hints everyone.

I used inSSIDer to find out what channels are used in the hood... surprise only two distant networks at channel 11. The window status thing will never show more than 65mbps... BUT inSSIDer does show 130mbit. I'm at -45db when right next to the router, and -51db two walls later.

So I guess it's just a display issue. Now if I could only find a way to get 5ghz... the router can do that, or? ... I'll RTFM!

http://i.imgur.com/o8iV3sH.png

http://i.imgur.com/dKUq8rL.png

0 Likes
Re: How to get 130mbit with MI424WR-GEN3I?
Amateur11
Newbie

In addition to your wireless router, the speed that you get depends on several things, not the least of which is the kind of built-in or usb wireless adapter you use with your client.  In addition, make sure that you are using a usb 2.0 port or better.  A first-generation usb port just will not do the trick.  Also, watch out for obstructions, i.e. walls, floors/ceilings and the like, and other interferences.

0 Likes
Re: How to get 130mbit with MI424WR-GEN3I?
Amateur11
Newbie

I want to add that a network, wired or wireless, works pretty much the same way as an audio entertainment system.  The overall performance will only be as good as what the weakest component of the system.  If your speakers are poor, don't expect the best output from your super amplifier and other components. Likewise, the best speakers depend on the capacity and performance of your amplifier and the rest.  If you have not done so already, upgrade to a wireless adapter that is capable of 150 mbps or better, to use on your computer, with your super router.

0 Likes
Re: How to get 130mbit with MI424WR-GEN3I?
slikone27
Newbie

The way I had to do mine to get that speed was to disable the wireless on the fios router and get a good router (mine is ASUS ac66u) to use as a WAP.  Then I split the 2.4 and 5ghz bands.  I can get all 150mbps on the 5ghz band.  Hope this helps.

0 Likes