Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone. OR get iPhone 13, on us for a limited time. With Select 5G Unlimited plans. Buy now
end of navigation menu
High Speed Internet Install Hangs

Another user already posted this problem but I seem unable to reply to that thread.

I am having *exactly* the same problem, namely:

Today is my Service Ready Date. I opened a browser and got the 'activation page', entered my line number, then got to download the verizon high speed internet installer for mac. Once I opened this I got to set up a username/password, then the installer went through a series of checks, and finally gets to 'saving settings for *******', where it says 'Please Wait, This step could take up to 3 minutes'. And it just hangs at that point. I waited for an hour and nothing happened. I tried again later with the 'resume installation' alias that was created when I quit the installer, and it jumps straight to that step as expected, but hangs again.


What could be causing this? I'm using a mac with MacOS 10.6, the modem is a Westell 7500, and the plan I've chosen is the 3MBs.


Thanks for any help!


Note: I copied the original poster's description of the problem because it is accurate in my case, revising only the OS version to reflect my own.


Link to original post



Re: High Speed Internet Install Hangs

Okay, replying to my own post here in case it helps someone else.

Just chatted with a rep who said my actual service wouldn't be activated until around 6 pm.

Personally, I think it's pretty dumb that I followed all the 'idiot proof' Verizon "Start Here" instructions, all indicators are green, I am obviously connecting to Verizon (their software downloaded) but my service is not yet activated to connect to the internet, and I have no way of knowing that without wasting an hour of my day troubleshooting and then contacting a rep.

So, I'm posting this in the hopes it will:

- save someone else the trouble

- reach the people who can change this at Verizon and fix this.

Bad start-up experience.

Also, by the way, the rep said I *do not* need to create a Verizon ID and "register" to connect to the internet - once the service is active I should be able to connect just fine and can even use my own modem.

Of course Verizon does not give you that impression at all.

Re: High Speed Internet Install Hangs

Update: 12 hours later.  Still not solved.

Utterly appalling.

After 20 minutes on hold waiting for a second support chat, then a 20 minute chat during which the rep repeatedly asked for information I'd already given, and then congratulated me and told me the service was working (it is not) ... the rep finally conceded they could not help me and said a Mac rep would call me on the phone in "20-30 minutes."

It's 90 minutes later.  No follow up, no call.

On my own I have re-started modem, re-started computer, trashed preferences for that Verizon activation software.

The last seemed to help.

Each time it got a little further.

Eventually it assured me I had completed the activation process. It gave me a confirmation.

Meantime Verizon has also e-mailed me saying congratulations, my service is up.

But when I try to connect to any page through the DSL in a browser, I keep being re-directed the Verizon activate / welcome page (which, believe me, I am pretty tired of seeing by now.)

... if I follow those steps, it tried to download the software *again* and start all over.

Seems I am in an inescapable loop.  Can I really be the only one who's had this problem?

I have now three times "activated" my internet service and still I am re-directed to the "activate" page.

I can only say, at this point, I wish there were an alternative to this terrible company.

Re: High Speed Internet Install Hangs
Super User
Super User

#1 Does this other thread help


#2 Can you get access to ?

Re: High Speed Internet Install Hangs

Did you find a solution to this problem? I'm having the same issue.