Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone. OR get iPhone 13, on us for a limited time. With Select 5G Unlimited plans. Buy now
end of navigation menu
Verizon router replacing source ip for incoming traffic
Enthusiast - Level 1


I recently switched to Verizon Fios GigE service from cablevision. I do a port forwarding to internal machine for ssh (port 22). I have some rules based on failed login attempts to ban the ip (fail2ban software). SInce I switched to FIOS, I can no longer use that as verizon does a NAT for incoming traffic as well and all of the traffic from outside seems to come from (router ip). Ideally this should only be done for outgoing traffic where the source ip gets replaced with public ip and not for incoming traffic. Is there a setting in router that can fix this behavior?


Re: Verizon router replacing source ip for incoming traffic
Enthusiast - Level 3

I'm surprised you're having this problem -- when I ssh into my servers from afar, the servers see me connecting from the remote host, not the router. And that, of course, is how things should be...

One of these servers is the DMZ host, and the other's ssh-port is reached via port-forwarding. For both of them connections look as one'd expect...