Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone. OR get iPhone 13, on us for a limited time. With Select 5G Unlimited plans. Buy now
end of navigation menu
wifi connected but no internet connection

So my "second office" (ie a public estabishment) has free wifi, but every day I go there  I can connect to their wifi but get "no internet connection" message.  so every day the restart their Verizon router and then I can connect.

My theory is the gateway gives out 255 addresses every day and is not releasing any DNS/DCHP  leases.  How can you configure a verizon router to expire a lease after X hours (probably 2-4 hours)  so the employees,  I (and other annoyed clients) do not have to deal with this issue anymore?

Re: wifi connected but no internet connection
Super User
Super User

Visit while connected to the Verizon router and log in using the credentials for the router, which are usually printed on a sticker found on the side of the router. Then go to My Network > Network Connections > Home/Office and click Edit. There should be an option there to adjust the DHCP lease time from whatever it is, to 3600 seconds (one hour) or something along those lines.

If the router is providing a guest network, then adjust these settings within the Guest network settings rather than change the Home/Office network settings.

You may also want to adjust the size of the DHCP subnet used for the visitors. Instead of a /24 subnet consider a /23 subnet. This can be adjusted by changing the subnet mask on the router from to This will increase the device count to a total of 512 (you'll get less due to loss caused by default gateway, the broadcast IP, and any other constantly connected devices).

Re: wifi connected but no internet connection
Super User
Super User

My router has a default lease time of 1 week.

If that is the case, employees should be able to reconnect using their same IP as the previous day. Shouldn't be locked out.

Probably don't want to set lease time too short as that can add overhead on network.

I would recommend maybe 30 mins less than time office closed or 30 min more that open, whichever is less.

BTW, you can verify if that is the issue by connecting to router. If you have an issue with internet, check ip address. If it is  169 IP, then you didn't get one.