Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
FTP Problems
fiatlux
Newbie

If I do an Internet speed test via any of my browsers my speed clocks at or better than what I have contracted for.  However, when I fire up my FTP client (I've tried several) and try to move files the speed drops into the teens kilobytes and or the connection times out.  Is anything special required to use FTP Port 21 via Verizon FIOS?

Thanks

0 Likes
Re: FTP Problems
Mikhail
Enthusiast

At least port 20. Do you use passive mode? Are you using NAT?

0 Likes
Re: FTP Problems
fiatlux
Newbie

Not using passive mode FTP.  Definitely using NAT; does anyone really have the courage to not run NAT? lol!  Anyway, the more I speak with Verizon the more I am coming to believe that traffic shaping is responsible for the problem. 

0 Likes
Re: FTP Problems
viafax999
Super User
Super User

Which way is your traffic, inbound or outbound?  Presumably inbound as you're talking about passive mode.

I've used it in both directions and it appears to run at speeeds consistent with my 25/25 connection.  I'm using Filezilla server with passive mode and non standard ports i.e. not port 21 - as soon as you open port 21 inbound you''l find your bandwith being consumed  by numerous would be hackes who appear to have automated sign on scripts that run for hours on end.

0 Likes
Re: FTP Problems
Mikhail
Enthusiast

@fiatlux wrote:

Not using passive mode FTP.  Definitely using NAT; does anyone really have the courage to not run NAT? lol!  Anyway, the more I speak with Verizon the more I am coming to believe that traffic shaping is responsible for the problem. 


Well, if you are running NAT (I prefer to run without NAT and deploy Linux as a firewall for a network -- I don't consider NAT as a good protective measure at all, but for home network leasing another 20 IPs from VZ is prohibitevly expensive, so I also use PNAT) then we need to know your config because NAT by itself does not let FTP work in active mode.

FTP uses port 21 for command and return code communications and port 21 on one side for data transfer. In active mode clients sends a request to get file and a port command which specifies your IP address and port server should connect to. Port is chosen (usually) by OS (software specifies 0 when it binds socket). Since client is behind NAT it does not know its external IP address and port is chosen in some random way, so server does't know how to connect to client port 21. Now there are clients that could use port range for this purpose and you can open those ports and use PNAT to map them onto your IP address. But issue with IP address is there. Some advanced clients could use something like DynDNS to get an external IP, some ask you to provide your IP (this approach does not work particaularly well with dynamic IP).

Saying that I should mention that I have my SFTP allocated on myhome network (which I use very rarely) and FTP at hosting service provider. I don't have problem like you described.

Re: FTP Problems
Mikhail
Enthusiast

If you are interested in SFTP solution (you need one port only and everything is encrypted) then you can take a look at http://wiki.filezilla-project.org/Howto -- I use both Filezilla server and client on all my OSes. I just use non standard port something like 10022.

0 Likes
Re: FTP Problems
fiatlux
Newbie

My FTP traffic is outbound from my server uploaded to other servers in the Internet.

0 Likes
Re: FTP Problems
Mikhail
Enthusiast

@fiatlux wrote:

My FTP traffic is outbound from my server uploaded to other servers in the Internet.


Then you should check your hosting services. Does your hosting services allows any scripting or script/CGI extensions? I see on a periodic bases that my FTP at hosting service provider site becomes much slower than they advertised. But I don't care since it's still around 1 mbps.

Re: FTP Problems
viafax999
Super User
Super User

@fiatlux wrote:

Not using passive mode FTP.  Definitely using NAT; does anyone really have the courage to not run NAT? lol!  Anyway, the more I speak with Verizon the more I am coming to believe that traffic shaping is responsible for the problem. 


Sorry, my earlier question was silly, didn't fully read your original post.

As you're just running an ftp client for posting and retrieving data from external ftp servers then there is nothing special on your end, no port, no port forwarding, nothing at all.  Also iIf you are managing to connect to the external servers the passive mode is not an issue either.

You may want to go and look at the sytem logs on your router when the issues are ocurring to see if there are any error messages appearing there.

Re: FTP Problems
Mikhail
Enthusiast

viafax999 wrote:As you're just running an ftp client for posting and retrieving data from external ftp servers then there is nothing special on your end, no port, no port forwarding, nothing at all.  Also iIf you are managing to connect to the external servers the passive mode is not an issue either.

Politely disagree. FTP protocol use always a pair of ports N and N-1, defaults 21 and 20. Port N is a command port and port N-1 is data port. Active mode has the following sequence of events:

1. Client sends RETR command.

2. Server looks for the file and answers with OK code if file exists.

3. Client sends PORT command where it specifies IP and PORT server should connect to.

4. Server connects and transfers data.

Now, if client is behind NAT the third step would not work. That is a reason, for example, in FileZilla client having a special cofiguration page -- Edit/Settings/FTP/Active Mode:

1. Check box Limit local port used by FileZilla.

2. Edit Box Lowest available port

3. Edit Box Highest available port

4. Radio Button Ask your OS for the external IP address.

5. Radio Button Use the following IP Address with Edit Box Use the following IP address.

6. Radio Button GetExternal IP address from the following URL with Edit Box.

How to use these different options I've explained earlier.

0 Likes