Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
G3100 Not work issue/bug
bav4688
Enthusiast

Hello,

I have a small web server at home and with this new router I am having a problem, I do not have access to the web server with the wan ip from the router network, but if I use a different network if I have access, everything worked perfectly with the old router, I have already tried everything within my reach and I cannot access my webserver from the router network, if anyone knows a solution I would greatly appreciate it.

Tags (2)
0 Likes
Re: G3100 Not work issue/bug
smith6612
MVP MVP
MVP

Verizon is apparently using Ports 443 and 80 for the NAT Hairpin already on the router. Does it work correctly if you use other ports? If so, change the port the router uses for remote management (if enabled, and you should keep it disabled btw) so it does not conflict with your web server. (Citing this thread: https://forums.verizon.com/t5/Fios-Internet/G3100-and-Hairpin-NAT-NAT-loopback/td-p/907397)

Alternatively, you can go into the router's DNS Settings and add a static DNS entry for your web server, so the domain resolves internally to your web server's IP rather than your WAN IP.

Re: G3100 Not work issue/bug
Cang_Household
Super User
Super User

No. 80 and 443 ports are not occupied unless you have enabled WAN side administration, which should be disabled for security reasons.

Could you screenshot your Port Forwarding page to see?

Re: G3100 Not work issue/bug
bav4688
Enthusiast

The ports are open since when I access my wan ip from another network I have access to the website, I am using DMZ Host.

0 Likes
Re: G3100 Not work issue/bug
bav4688
Enthusiast

This worked for me but having more than one domain assigned to my server is not viable because if I add more than one hostname to the router none work.

Thanks

0 Likes
Re: G3100 Not work issue/bug
Cang_Household
Super User
Super User

Do not configure the DMZ as that is difficult to secure. Again, could you screenshot the Port Forwarding page?

Domain names of your website should be configured in your domain Registrar’s DNS server, not on your router.

Another thing is hosting servers for commercial purposes is a violation of ToS.

Re: G3100 Not work issue/bug
dslr595148
Super User
Super User

More than likely it is a loopback/hairpin/Reverse NAT.

One of the ways to check for this/that, I point to https://www.pcwintech.com/test-for-reverse-nat

Re: G3100 Not work issue/bug
bav4688
Enthusiast

I think you misread what I wrote or maybe I wrote something wrong.

The web server works and the ports are open to the public if you are example on your phone and you are using mobile data you can enter the website but if you connect to the wifi of my router you do not have access to the website, if I use the network of my router I can not access the website of my server, but if I do it from another network outside my router I can access the website.

I already have the dns servers pointing to my public ip and they resolve the domain names perfectly.

Thanks in advance.

0 Likes
Re: G3100 Not work issue/bug
Cang_Household
Super User
Super User

Ok. Now it sounds like a NAT hairpinning issue.

The packet has the same source and destination IP address. This type of packet is by default dropped by the Linux kernel if I am not mistaken.

Let me ask a question, why don't you switch instead of route within the same network? If you server and client are both in the same LAN, why both route through the router when you can switch through a layer 2 bridge? You can just go to your local DNS server on G3100 and add some static entries.

Now, your mentioning of adding hostnames make sense. You are trying to rely on the automatic G3100 DNSmasq population based on DHCP and NetBios hostname. I think one host can only have one host name, unless you do network namespaces or other virtualized namespaces.

Why not just configure your local DNS server? Or even just add static DNS entries on your client device. Should be an one-liner.

Re: G3100 Not work issue/bug
bav4688
Enthusiast

It's a problem with my router call verizon they say they will fix it, it's a problem with the loopback.

0 Likes