Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
Internet not working on Mobile
Alex1759
Enthusiast

There's a problem with internet on my office. Internet work perfect on my laptop/all PC's. But its not working on my smart phone. What the problem ?.

0 Likes
1 Solution

Correct answers
Re: Internet not working on Mobile
gs0b
Super User
Super User

MAC address filtering is a setting on the router.  Since it's not your router, is it possible the owner doesn't want you using their internet?  They could be using MAC address filtering to prevent you from connecting.

If you are allowed to use this router, you should get the owner involved to check the router's settings.

You mentioned this is an office environment.  There may be rules put in place by the organization's security team about which devices are allowed to connect to WiFi.  While this may be enforced through MAC address filtering, their could be a lot more going on.  You may need to talk to the office's IT department to determine if your phone is allowed to connect, and if so, what steps need to be taken to connect it.

View solution in original post

Re: Internet not working on Mobile
jonjones1
Legend

Go into settings on your smart phone (wifi) make sure first it is turned on. If it is on look for the SSID of the network you want to connect to. Click on it then log on with your password.

if you have to you can click the network name and say forget network. Then turn your phone on and off look for the network again and try connecting.

that should fix the issue.

Re: Internet not working on Mobile
Alex1759
Enthusiast

I tried everything one of my colleague said there's something MAC address Filter. What is it how can i bypass ?

0 Likes
Re: Internet not working on Mobile
dslr595148
Super User
Super User

@Alex1759 wrote:

I tried everything one of my colleague said there's something MAC address Filter. What is it how can i bypass ?


To know what to do, if would help to know the..

#1 ...brand and model of your Router. For example Westell 7500.

#2 ...OS and Version on the phone. For example Android 11.

Re: Internet not working on Mobile
Alex1759
Enthusiast

Its not my router btw its tenda wireless router

and i am using Samsung A10s its Android 10 based

0 Likes
Re: Internet not working on Mobile
dslr595148
Super User
Super User

@Alex1759 wrote:

Its not my router btw its tenda wireless router

and i am using Samsung A10s its Android 10 based


Ok.

We can not tell what to do in the router since did not provide the model of it (as it not yours), but I can tell what to check in Andriod 10.

In Andriod 10 go to Settings -> Connections -> Wi-Fi. For the wireless network that you want to connect to, select it and for the MAC Address Type make sure that it says Phone MAC.

Then go to Advanced. For IP Settings make sure that it says DHCP and for the Proxy make sure that it says None.

Re: Internet not working on Mobile
gs0b
Super User
Super User

MAC address filtering is a setting on the router.  Since it's not your router, is it possible the owner doesn't want you using their internet?  They could be using MAC address filtering to prevent you from connecting.

If you are allowed to use this router, you should get the owner involved to check the router's settings.

You mentioned this is an office environment.  There may be rules put in place by the organization's security team about which devices are allowed to connect to WiFi.  While this may be enforced through MAC address filtering, their could be a lot more going on.  You may need to talk to the office's IT department to determine if your phone is allowed to connect, and if so, what steps need to be taken to connect it.

Re: Internet not working on Mobile
dslr595148
Super User
Super User

@Alex1759 wrote:

I tried everything one of my colleague said there's something MAC address Filter. What is it how can i bypass ?


Since you provided that you are on Andriod 10 to bypass it,

#1 go to Settings -> Connections -> Wi-Fi. For the wireless network that you want to connect to, select it and press Forget.

#2 Then go back to Connections. Then go to Data Usage. Where it says Mobile Data, turn that on.

#3 Success.

#4 But I agree with post 7 of this thread if you want use the Wi-Fi network and not use Mobile Data. 😉

Re: Internet not working on Mobile
Alex1759
Enthusiast

Its solved now guys. The IT Department blocked my mac address. Thanks for your advice