Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
Port forwarding problem
duari91
Enthusiast

Router= Actiontec  MI-424-WR Rev.D

Hello all! I have been trying to search the internet for a while with a solution to my problem. I have yet to come close to solving this....

I am trying to start my own servers on my computer to host my friends with games that we play...

So I log into my router, click port forward, and then "advanced". I then select my ip address from the drop down, and then select custom port from the drop down. I fill in the info from the addition drop downs which is...

(Protocol=both  Source Ports=Any  Destination ports=specify (I put in the port I want to forward to which is 25565 in this case)  Schedule=Always  Forward to Port=Same as Incoming  WAN connection type=All broadband devices)

After everything is filled in correctly, I click the "apply" button to save the changes, and apply. This is where my problem persists. Instead it configuring, it gives me this error message...

"INVALID RULE: The desired port range is not allowed to be configured."

Does anyone know why I would be getting this message? It does this for ANY port number that I put in.

Also, it ONLY does this when the Protocol=Both or Protocol=UPD, the TCP works.

I welcome ANY input of help, 

Thanks!

Re: Port forwarding problem
Anti-Phish1
Master

@duari91 wrote:

(Protocol=both  Source Ports=Any  Destination ports=specify (I put in the port I want to forward to which is 25565 in this case)  Schedule=Always  Forward to Port=Same as Incoming  WAN connection type=All broadband devices)

After everything is filled in correctly, I click the "apply" button to save the changes, and apply. This is where my problem persists. Instead it configuring, it gives me this error message...

"INVALID RULE: The desired port range is not allowed to be configured."


I've seen an issue where VZ created a port forward for one of the STBs to open ALL UDP ports to that STB.

This prevents you from adding 25565 UDP since it is already in use.

If this is the case, you should be able to see a PF listed with a port range of 0-65365.

I was able to get around it by powering off the STBs, then doing a hard reset on the router.

This clears all the VZ defined port forwards. I was then able to add the UDP port forward I needed.

Only after the port was successfully added did I power up the STBs.

I can't for the life of me understand why VZ would PF all UDP ports to one of the STBs.

I'm running a rev. C with 4.0.16.1.56.0.10.12.3 firmware.

If you're port forwarding for Minecraft, AFAIK, only TCP is needed.

Re: Port forwarding problem
prisaz
Legend

Search on port forwarding results.

http://forums.verizon.com/t5/forums/searchpage/tab/message?filter=location&location=Node%3AFiOS_Inte...

Also if you are hosting or running games on the Actiontec, you may run into NAT issues with the number of connections the router will support.

Also keep in mind the Terms of Service. While I have never heard of anyone running into issues with this, it is there incase there are issues with your connection.

http://my.verizon.com/central/vzc.portal?_nfpb=true&_pageLabel=vzc_help_policies&id=TOS

Restrictions on Use.

"You also may not exceed the bandwidth usage limitations that Verizon may establish from time to time for the Service, or use the Service to host any type of server. Violation of this section may result in bandwidth restrictions on your Service or suspension or termination of your Service."

0 Likes
Re: Port forwarding problem
duari91
Enthusiast

Would you be able to give me a step by step process? I am new to anything networking, so i have trouble trying to fix anything network related.

Re: Port forwarding problem
prisaz
Legend

@duari91 wrote:

Would you be able to give me a step by step process? I am new to anything networking, so i have trouble trying to fix anything network related.


Try these links. There is no one size fits all to port forwarding. It all depends on the software you are running and what you are trying to do. Many variables.

http://www.portforward.com/english/routers/port_forwarding/Actiontec/MI-424-WR/MI-424-WRindex.htm

0 Likes
Re: Port forwarding problem
duari91
Enthusiast

I am saying that I need a step by step process to fix my problem, not forward the ports. I learned how to port forward, but again the problem that I am having persists. 

Re: Port forwarding problem
prisaz
Legend

Ok. I follow your configuration step by step as in your first post. It worked for me. It could be a conflict with an existing rule or something odd in your router. Have you tried resetting your router back to factory defaults by pressing the reset with a paper clip? Here is a clip of my router model and screen shot of all my rules with yours added. I hope you get it to work.

image

image

UPDATE If you have a newer firmware revision, there was a bug in the newer firmware that caused different problems. You my need to go into the advanced tab and turn off automatic updates, and revert back to the revision shown.

These firmware numbers are from the Actiontec site. For revisions A-D it is shown in red. Which may indicate a problem. I have heard that you can select firmware restore to go back to the previous revision. I had tech support work on my router and I believe they put mine at the revision it currently shows in my clip above. So I am not going to break it.

MI424WR - A,C,D 4.0.16.1.56.0.10.14.0
MI424WR - E & F 20.10.7
MI424WR - G 30.16.0

0 Likes
Re: Port forwarding problem
duari91
Enthusiast

I tried pressing the reset button, to reset to defaults, and that did not work. It wiped all the other port forwards on the router, but the UDP still did not work.

my current version is 4.0.16.1.56.0.10.14.0 with the automatic update disabled.

Any other suggestions?

Re: Port forwarding problem
prisaz
Legend

@duari91 wrote:

I tried pressing the reset button, to reset to defaults, and that did not work. It wiped all the other port forwards on the router, but the UDP still did not work.

my current version is 4.0.16.1.56.0.10.14.0 with the automatic update disabled.

Any other suggestions?


Downgrade your router firmware by using firmware restore. If that is not possible you can download the latest supported working firmware file from Verizon. Or call tech support for them to downgrade your firmware. This is the latest revision stored on the Verizon site. From what I have heard the 14.0 has issues with port forwarding that support various features such as DVR remote access, and caller ID. As noted the 14.0 version is shown in red on the Actiontec site for a reason. http://support.actiontec.com/doc_files/Current_Firmware_Versions.pdf It has BUGS.

File name 4.0.16.1.56.0.10.12.3-MI424WR.RMT This is the version that I am running and it works fine as shown.

Download the file to your PC and try to restore the previous version. Or as I said contact support if you are concerned with doing this.

http://www2.verizon.net/micro/fios_router_update/

You can load the router firmware from a file stored on your local computer by choosing Upgrade from a computer in the network. And choose the file from your local drive. Like I said, "If you are not comfortable with doing this, please contact tech support". http://www22.verizon.com/content/contactus/

Ignore the part that says go to upgrade.actiontec.com. Use the router update link provided above, and get your upgrade from Verizon. They know what works and will provide the best possible solution.

image

Since we have determine it to be a firmware related issue, I hope this advice helps.

0 Likes